跳到论文正文
W Papers独立论文阅读器 arXiv:2303.12403 论文正文 计算阅读时间 · 0%
引用这篇论文根据当前论文元数据生成,正式投稿前建议核对。

    
  
License: arXiv.org perpetual non-exclusive license
arXiv:2303.12403v1 [cs.NI] 22 Mar 2023

A Resource Efficient Implementation of the RESTCONF Protocol for OpenWrt SystemsPubID: pubid: 978-1-7281-4973-8/20/$31.00  © 2020 IEEE

Malte Granderath Affiliation: Computer Science, Jacobs University Bremen, Germany
malte.granderath@gmail.com
   Jürgen Schönwälder Affiliation: Computer Science, Jacobs University Bremen, Germany
j.schoenwaelder@jacobs-university.de
Abstract

In recent years, the open source operating system OpenWrt has become a popular option for replacing proprietary firmware on networking devices such as home routers or access points. In order to configure an OpenWrt system, like setting up firewall rules, the user has to either sign in to the web interface or use SSH to manually change configuration files on the device. While the current approach is sufficient for small home networks, it only allows for limited automation of management tasks and configuration management becomes time-consuming, for example, on larger campus networks where access control lists on OpenWrt access points need updates regularly.

This paper describes our efforts to implement the RESTCONF configuration management protocol standardized by the IETF on OpenWrt systems that have limited CPU and memory resources. We detail our design choices that make our implementation resource efficient for the use cases we target and we compare our implementation against other similar solutions. Our implementation is available on GitHub under an open source license11 1 Available from https://github.com/mgranderath/orc under BSD-3.

Index Terms: 
RESTCONF, OpenWrt, YANG, network management

I Introduction

The IETF has standardized a new network management protocol called RESTCONF [1] that supports a subset of the functionality of NETCONF [2]. RESTCONF uses HTTP [3] as a substrate and hence any tool or programming language that can invoke HTTP operations can be used to implement management applications. RESTCONF provides a programmatic interface for installing, changing, or deleting configuration data, which is accessible via HTTP methods. The protocol supports different data encodings (e.g., XML [4] and JSON [5]). The exposed API is data-model-driven. The data models are written in the YANG [4] data modeling language and define the resources exposed by the RESTCONF server. The original version of RESTCONF supported a single unified datastore abstraction exposing both configuration and state data. The more recent for network management datastore architecture [6] has led to RESTCONF extensions that can expose multiple configuration datastores and a separate operational state datastore [7].

The OpenWrt open source project is creating and maintaining an embedded operating system based on the Linux kernel, which is mostly used on networking devices, such as home routers and access points. All OpenWrt components have been optimized to run efficiently on embedded devices with limited resources. A typical system running OpenWrt has at least 8MB of flash memory and at least 64 MiB of main memory. Systems with 16 MiB flash and 128 MiB main memory are quite common at the time of this writing. OpenWrt implements a fully writable and accessible file system and it provides a package management system allowing users to easily install additional applications [8]. The OpenWrt system implements a special approach to configuration file management, which is called the Unified Configuration Interface (UCI). It enables the unified management of all configuration information of the system. UCI keeps configuration information separated from the parts of the system that are essentially read-only.

While looking for a RESTCONF implementation that runs efficiently on OpenWrt platforms, we found that open source implementations were either attempts to port implementations originally written for much more resource rich platforms over to OpenWrt or they were written with embedded systems in mind but still designed to consume resources even when no management interactions take place. Hence, we wanted to find out how resource efficient a RESTCONF implementation running under OpenWrt can be made. In particular, we wanted to avoid long running processes that constantly consume memory. Since we also wanted to achieve good response times, it was crucial to minimize the startup time of the RESTCONF subsystem.

The rest of the paper is structured as follows. In the Section II, we provide a brief introduction to the UCI subsystem used by OpenWrt to store configuration information. We then review a few basics of the RESTCONF protocol and the YANG data modeling language in Section III before we discuss related work in Section IV. We describe our solution in Section V and provide an evaluation in Section VI before we conclude the paper in Section VII.

II Unified Configuration Interface

Linux systems usually store configuration files in the /etc directory tree and the configuration files use various file formats. OpenWrt tries to unify the format and location of the configuration files through the unified configuration interface (UCI). UCI configuration files are stored in the /etc/config directory and all UCI configuration files have the same format. Due to this unifying approach, configuration data can be exposed and manipulated easily via a common application programming interface (API).

A UCI file usually represents a UCI package, i.e., it contains all configuration information for a specific component of the system. UCI configuration files are divided into sections. Sections start with a config keyword followed by a section type name identifying the type of the section. Sections can be named or unnamed: a named section is identified by an additional name and the same section can appear multiple times with different names; unnamed sections usually only appear once in a configuration file. Inside the sections, configuration options are defined using the option keyword followed by the option type name and a value. The list keyword declares a list of name value pairs, utilizing the same list name for several items. Note that the format does not allow for nested sections.

config system
option hostname "OpenWrt"
option timezone "UTC"
# ...
config interface "en0"
option ip6addr "2001:db8::42/64"
option ip6gw "2001:db8::1"
# ...
config vnstat
list interface "en0"
list interface "en1"
# ...
Fig. 1: Examples of UCI configuration sections

Figure 1 shows examples of UCI configuration sections. The first section is unnamed and defining system options. The second section is named and defines options for the interface named en0. This third section is again unnamed and defines a list of interfaces that should be used for statistics collection.

OpenWrt ships with a small C library (libuci) to access UCI files. It exposes multiple functions that can be used to read, write, or modify the configuration data. The library handles the locking of the configuration files during changes and prevents write collisions. It also exposes some further additional functions that help validate values and names of sections. The uci command line utility can be used interactively on the command line to make changes. The web user interface LuCI is written in Lua [9] and uses the libuci as well to access and manipulate configuration files.

III RESTCONF and YANG

YANG [4] is a data modeling language that was designed to model data accessed and manipulated by configuration management protocols like RESTCONF or NETCONF. YANG models configuration and state data in a hierarchical fashion with essentially four elements:

  • •

    A leaf schema node models simple data of a simple data type. A leaf node instance has exactly one value and no child nodes.

  • •

    A leaf-list schema node models an ordered sequence of simple data of one specified simple data type. A leaf-list instance can have zero, one, or multiple values.

  • •

    A container schema node groups related schema nodes into a sub-tree. A container instance does not have a value but it can contain child nodes of any type.

  • •

    A list schema node defines a sequence of list entries. Each list entry acts as a container. A list schema node for configuration data is required to define the child elements that form a key identifying list instances.

YANG has been used to define data models covering, for example, network interfaces [10] or general system aspects [11].

The RESTCONF specification maps hierarchical models defined in YANG modules to a hierarchical set of resources that can be accessed and manipulated by invoking HTTP methods on them. The data exchanged between a RESTCONF client and a RESTCONF server can be encoded in either XML or JSON. RESTCONF uses HTTP methods to realize the create, read, update and delete (CRUD) operations needed to manipulate configuration data [1]:

  • •

    The OPTIONS method is used to discover which operations are possible for a specific resource.

  • •

    The GET method is used to retrieve data and header fields of a specific resource.

  • •

    The HEAD method only returns the header fields of a GET request.

  • •

    The POST method is used to create a new data resource (or to invoke an operation)

  • •

    The PUT method can create new data resources, like POST, but, if the resource already exists, it replaces the existing resource.

  • •

    The PATCH method is used to modify an existing resource.

IV Related Work

Several of open-source RESTCONF implementations can be found by searching through public git repositories and digital libraries.

JetConf is a RESTCONF implementation that is implemented entirely in Python. It supports the JSON encoding and only HTTP/2 as the HTTP transport. JetConf has dependencies on several non-standard Python libraries that have to be installed. This means that only systems having the Python interpreter and those libraries installed will be able to run the RESTCONF implementation [12]. The developers mention that this implementation is not suitable for low-end OpenWrt routers [13]. Note that OpenWrt systems usually do not come with Python installed since the Python language environment is relatively expensive in terms of resource requirements.

MD-SAL is an infrastructure component of the OpenDaylight (ODL) project that supports NETCONF and RESTCONF. It is implemented in Java and supports several transports and payload formats [14]. RESTCONF is part of the MD-SAL artifact and cannot be installed standalone. There is only limited Java Virtual Machine (JVM) support on OpenWrt and only stripped down JVM’s are available for installation such as JamVM [15]. Hence, this implementation is not suitable for OpenWrt devices.

Clixon is a YANG based configuration manager with both NETCONF and RESTCONF interfaces and an interactive command line tool. Clixon provides the core system and can be used as-provided but it also exposes an API for plugins, such that additional functionality can be implemented. It also has dependencies on some non standard libraries. Clixon is built as a system of services that utilize Remote Procedure Calls (RPC) to communicate with each other. When running RESTCONF there have to be three processes running. It needs a web server with support for FastCGI, the backend daemon and the restconf daemon. Therefore, on systems that only have small numbers of configuration changes, resources are consumed whether or not RESTCONF is needed at that point in time [16].

V Solution Overview

For our RESTCONF implementation, orc, to be able to run on all devices that run OpenWrt, we focused on adhering to the functionality that is provided in a base installation of OpenWrt. We assume that the devices do not have to handle hundreds or thousands of RESTCONF requests per minute but rather have to handle configuration changes that arrive only occasionally. This means that our implementation should not consume any resources when no configuration transactions are taking place. For integration with OpenWrt the UCI system should be used as a datastore. This means that we have to map between the different data formats. An additional requirement that we set for our implementation is to depend on as few non-standard libraries as possible and to utilize only libraries that have a small package size.

V-A Architecture and Design Decisions

The architecture of our implementation is best explained using the time sequence diagram shown in Figure 2.

Fig. 2: Architecture of the implementation

The uHTTP web server was implemented specifically for the OpenWrt operating system and it supports the Common Gateway Interface (CGI) [17]. We decided to build our implementation orc as native binary that can be executed via the CGI mechanism of uHTTP, see Figure 2. This ensures that other applications can use the same web server (most notably LuCI) and orc will only be executed when requested. This reduces the consumption of resources compared to having our implementation built integrated with its own web server. This design has the added benefit that the native binary can be used with any web server that supports the CGI.

When orc is executed, it interprets the request using the provided YANG models and then, depending on the request, reads or writes to the UCI using the libuci library that is pre-installed on OpenWrt systems. Our implementation also maps between the data formats so that JSON configuration data received from a RESTCONF client can be stored in the proper UCI format. The libuci writes and reads the configurations stored in the /etc/config directory and then, if required, a /etc/init.d script can be executed to convert the UCI configuration into formats that are interpreted by the applications and services. This is visualized by the /etc directory in Figure 2.

V-B Mapping YANG and UCI

For utilizing the UCI system we need to be able to interpret the UCI file format in relation to YANG data models. This can be achieved by adding annotations to the YANG modules. The following annotations can be added to YANG modules:

  • •

    The package annotation is used to set the UCI package name of the sub-tree.

  • •

    The section annotation is used to set the UCI section type of the sub-tree. This has to be specified for a list.

  • •

    The section-name is used to set the UCI section name of the sub-tree.

  • •

    The option annotation is used to set the UCI option and list names for leafs and leaf-lists.

  • •

    The leaf-as-name annotation is optional and can be used to define which leaf holds the value that should be used as section-name

module example {
uci:package "example";
container device {
uci:section "device";
uci:section-name "device";
leaf enabled {
uci:option "enabled";
...
}
list interface {
uci:section "interface";
uci:leaf-as-name "name";
...
}
}
}
Fig. 3: Example of an annotated YANG module

The following rules apply for these YANG extensions:

  1. 1.

    The package, section and section-name annotations can be overridden in the same sub-tree by specifying them again. This allows for splitting up a complex module into different UCI files and sections.

  2. 2.

    The option annotation can only be used to annotate leafs or leaf-lists and cannot be overridden.

  3. 3.

    If just a section is defined for a container, then section-name is implicitly declared as empty.

  4. 4.

    A list node must have a section defined but no section-name (as seen in Figure 3). It can, however, use the leaf-as-name annotation to use a value of a leaf as a section-name.

  5. 5.

    The UCI restrictions concerning allowed characters etc. apply.

V-C Representing a YANG model in JSON format

YANG models can be represented in the native YANG format or an XML rendering called YIN [4]. We looked at several libraries for parsing the native YANG format or generic XML libraries for parsing the YIN format but they all come with significant overhead. We therefore decided to render YANG models into a JSON representation in an additional preprocessing step so that we can read YANG modules at runtime using a JSON parser. On OpenWrt, the json-c library comes preinstalled since it is used by other applications on the system.

{
"type": "module",
"package": "example",
"map": {
"device": {
"type": "container",
"section": "device",
"section-name": "device",
"map": {
"enabled": {
"type": "leaf",
"option": "enabled",
...
},
"interfaces" {
"type": "leaf-list",
"section": "interface",
"leaf-as-name": "name",
...
}
}
}
}
}
Fig. 4: The annotated YANG example converted to JIN

Since there was no previous work that allowed for conversion of a YANG model into a JSON representation, a new conversion was developed. The first step is the conversion from YANG to YIN and the second step is the conversion of the YIN XML representation to JSON. The JSON is then processed to simplify it for our targeted usage. The YANG representation in JSON will be referred to as JIN from here on. Figure 4 shows the conversion of the YANG module example shown in Figure 3 into the JIN format. We have left out the mapping of the namespaces for improved readability.

V-D Converting UCI to JSON

For returning JSON data in a response to a GET request, the existing UCI content has to be mapped to JSON based on the YANG data model. From the request URI that is passed to the CGI script, the JIN module can be traversed to find the targeted node. At each step of traversal, the JIN node is checked for UCI annotations, defined in Section V-B, and the UCI path is stored in an object that is passed on to the next iteration. Once the target node is reached the UCI path up to that node will be defined.

From this node, a recursive depth-first traversal is started that reads and stores the UCI annotations at each node and passes it on to the children. There are different cases depending on which node is reached during the traversal:

  • •

    For leaf or leaf-lists, the UCI path should be complete pointing at a specific UCI option or list. This value is then read using libuci and returned to the parent.

  • •

    There is a particular case for lists. As stated in Section II, sections can be accessed using an index and, therefore, the number of sections of a section type can be used to iterate through the list, and the index is passed down to the children on continuing the recursion on the sub-nodes.

module: example
+--rw device
+--rw name? string
...
+--rw interfaces* [name]
| +--rw name string
| +--rw enabled boolean
...
+--rw applications* string
Fig. 5: Simplified YANG module tree representation.

Taking the module from Figure 5 as an example of this process, with the URI /data/example:device, the following traversal will be executed:

  1. 1.

    name →\rightarrow read UCI value

  2. 2.

    interfaces →\rightarrow for ii in list_length (list_length = 1)

    1. (a)

      interfaces[i].name →\rightarrow read UCI value

    2. (b)

      interfaces[i].enabled →\rightarrow read UCI value

  3. 3.

    applications →\rightarrow read UCI value

At every step of the traversal, the return value of the child will be combined with the key from JIN to produce JSON.

V-E Converting JSON to UCI

While for converting UCI to JSON a traversal through JIN has to be executed, for converting JSON to UCI, a parallel traversal of JIN and JSON has to be done. Every object in the JSON representation has to be compared to the nodes in JIN. Similarly to the conversion of UCI as JSON, the request URI is also used to traverse to the target node. During this traversal, the individual nodes can be checked for existence depending on whether it is a PUT or POST request.

After traversing to the target node, the root key of the JSON should represent the JIN resource that is targeted or its parent. From this, a depth-first traversal can be run on the combined JSON and YANG tree. In case the JSON is not targeted at adding a list item, the content has to be flattened according to the UCI annotations and no knowledge about the existing file content has to be known except if they exist. The JSON key-value pairs will be converted to UCI path, value and type triples that can then be written after traversal. The return cases of this recursive depth-first traversal are as follows:

  • •

    For a leaf, a triple of the UCI path, JSON value and type ”option” will be returned.

  • •

    For a leaf-list, a list structure of triples of the UCI path, JSON value and type ”list” will be returned.

  • •

    For each item in a list the recursive traversal is continued but with the index passed in the UCI path object. The results are combined into a list structure and returned.

  • •

    For a container the traversal is continued, but an additional triple is added of UCI path, no value and type ”container”. This is later used to create the named section.

After this step, the JSON has essentially been flattened into a list of UCI paths to values. The changes can then be written using libuci by iterating through the list.

{
"example:device": {
"name": "Router_0",
"interfaces": [{
"name": "eth0",
"enabled": true
}],
"applications": [
"uhttpd",
"luci"
]
}
}
Fig. 6: Example JSON request for the module in Figure 5

For example, the request URI /data/ with the JSON content in Figure 6 will output the following list when processed together with the restconf-example module:

"example.device", container,
"example.device.name", option, "Router_0"
"example.device.@interfaces[0].name", option, "eth0"
"example.device.@interfaces[0].enabled", option, "true"
"example.device.applications", list, "uhttpd"
"example.device.applications", list, "luci"

In case a list item is to be added to an already existing list the above principles still apply, but instead of initializing the list index at zero, it will be initialized with the list length.

V-F Verifying JSON against YANG constraints

One of the features of YANG and RESTCONF is the verification of configuration data against the constraints defined in the data model. Our implementation does not verify the data when reading from UCI since it is assumed that if there are other changes to the configuration files, they will be verified by the entity or tool causing those changes. However, for writing JSON as UCI, the verification of a subset of the YANG constraints has been implemented. The general verification of the JSON structure is completed while traversing through the tree.

During the conversion from YANG to JSON (see Section V-C) the typedefs and imported types are extracted into a separate list. This list simplifies the lookup of type information during verification. The verification of types is implemented as part of the process of writing JSON as UCI. Whenever a leaf or leaf-list is reached during traversal, the content in the JSON is verified according to the following steps:

  1. 1.

    The type declaration is retrieved either directly from YANG or the list of typedefs and imported types.

  2. 2.

    The content is compared to the lexical representation of the base built-in types defined in RFC 7951 [5].

  3. 3.

    In case a pattern or range restriction is defined, the content is also verified against these restrictions.

Verification of unique and key semantics of lists has also been implemented. For lists, the key and unique statement values are first extracted from the converted module and then a simple iterative comparison is done on all items. In the case that a list item is added, the value of that item has to be compared to the already existing values, so in that case, the existing items are first read from the UCI and added into a list that is then verified. This is similar to the verification of leaf-lists, where only single values have to be compared.

V-G Limitations

The main restriction that is imposed by the difference in UCI and nested data structures is the nesting of a container or list in another list. The problem in the current implementation is to indicate which child item, of a list item, belongs to each list item. This can easily be demonstrated by the following example.

config interface
option name "eth0"
...
config interface
option name "eth1"
...
config nested nested
Fig. 7: Nested Container in List item.

If a container nested is added to the interfaces list in the example module (see Figure 5), the UCI configuration file will look like shown in Figure 7. The nested section can belong to either of the interface sections. This could be solved by changing the name of the section to contain a reference to the list item it belongs to.

VI Evaluation

The main goal of our implementation is to run with low overhead on systems with limited resources. We target deployment scenarios where management transactions occur infrequently. The following statistics were collected using a virtual machine (x86_64 architecture) running OpenWrt 18.06.2 with 64 MiB64\text{\,}\mathrm{MiB} of RAM. Our implementation depends on several libraries. The package sizes of all dependencies can be found in Table I.

TABLE I: Total package library size
Library Size
libjson-c 14 KiB14\text{\,}\mathrm{KiB}
libuci 13 KiB13\text{\,}\mathrm{KiB}
libubox 16 KiB16\text{\,}\mathrm{KiB}
Total 43 KiB43\text{\,}\mathrm{KiB}

The memory space required by the libraries is kept at an absolute minimum, not even requiring 0.05 MiB0.05\text{\,}\mathrm{MiB} of the flash memory. In the official documentation, it is stated that a minimum of 4 MiB4\text{\,}\mathrm{MiB} of flash is needed for installation of OpenWrt and a minimum of 32 MiB32\text{\,}\mathrm{MiB} of RAM is recommended [18].

TABLE II: Evaluation result
ORC Clixon
Test Heap Time Heap Time
GET 1.1 MiB1.1\text{\,}\mathrm{MiB} 0.00 s0.00\text{\,}\mathrm{s} 5.9 MiB5.9\text{\,}\mathrm{MiB} 0.09 s0.09\text{\,}\mathrm{s}
POST 1.1 MiB1.1\text{\,}\mathrm{MiB} 0.07 s0.07\text{\,}\mathrm{s} 6.3 MiB6.3\text{\,}\mathrm{MiB} 0.02 s0.02\text{\,}\mathrm{s}
PUT 1.1 MiB1.1\text{\,}\mathrm{MiB} 0.07 s0.07\text{\,}\mathrm{s} 6.3 MiB6.3\text{\,}\mathrm{MiB} 0.02 s0.02\text{\,}\mathrm{s}
DELETE 1.1 MiB1.1\text{\,}\mathrm{MiB} 0.01 s0.01\text{\,}\mathrm{s} 6.1 MiB6.1\text{\,}\mathrm{MiB} 0.01 s0.01\text{\,}\mathrm{s}

Our orc implementation has been tested against the clixon implementation. We measured the maximum heap size and the time to complete requests. For testing we used an example YANG module that can be found on github22 2 https://github.com/mgranderath/orc/blob/master/yang/restconf-example.yang. The time utility was used to measure the time to completion and the valgrind massif tool was used to measure the maximum heap size.

Clixon needs a web server with support for FastCGI, the clixon_backend service, and clixon_restconf process to be constantly running. When utilizing the example setup from the clixon documentation, the following idle heap size can be collected: clixon_restconf uses 2.4 MiB2.4\text{\,}\mathrm{MiB} and clixon_backend uses 2.9 MiB2.9\text{\,}\mathrm{MiB}. The result of our measurements are summarized in Table II. While our implementation has a lower maximum heap size, it has slower response times for POST and PUT requests. However, the response times are still well below 0.1 s0.1\text{\,}\mathrm{s} and since orc is not constantly consuming memory resources, we believe that orc is a far more efficient solution for systems that do not receive a constant stream of configuration management requests.

VII Conclusions

We described the design of our RESTCONF protocol implementation for OpenWrt systems called orc. We have outlined how orc maps between the OpenWrt UCI format used as the configuration datastore and the nested data format used by YANG models.

Our comparison of orc against an existing implementation (clixon) has shown that we can achieve a much lower memory footprint. Furthermore, orc does not consume any resources when no RESTCONF transactions take place.

Our implementation has some limitations that arise from the mapping of the data models (flat UCI versus nested YANG). Our future work includes extending the JIN parser with more YANG features and reducing the limitations in the mapping of the data models. In addition, we are working towards integrating orc with our implementation of standards for large-scale measurement frameworks and evolving standards for network and device security (denial of service signaling, remote attestation) that use RESTCONF as a substrate.

Acknowledgements

This paper has received funding from the European Union’s Horizon 2020 Research and Innovation program under the CONCORDIA cybersecurity project (GA No. 830927).

References

  • [1] A. Bierman, M. Björklund, and K. Watsen, “RESTCONF Protocol,” RFC 8040, Jan. 2017.
  • [2] R. Enns, M. Björklund, J. Schönwälder, and A. Bierman, “Network Configuration Protocol (NETCONF),” RFC 6241, Jun. 2011.
  • [3] R. Fielding and J. Reschke, “Hypertext Transfer Protocol (HTTP/1.1): Message Syntax and Routing,” RFC 7230, Jun. 2014.
  • [4] M. Björklund, “The YANG 1.1 Data Modeling Language.” RFC 7950, Aug. 2016.
  • [5] L. Lhotka, “JSON Encoding of Data Modeled with YANG,” RFC 7951, Aug. 2016.
  • [6] M. Björklund, J. Schönwälder, P. Shafer, K. Watsen, and R. Wilton, “Network Management Datastore Architecture (NMDA),” RFC 8342, Mar. 2018.
  • [7] ——, “RESTCONF Extensions to Support the Network Management Datastore Architecture,” RFC 8527, Feb. 2019.
  • [8] “Openwrt project.” [Online]. Available: https://openwrt.org/
  • [9] R. Ierusalimschy, L. de Figueiredo, and W. Celes, “A Look at the Design of Lua,” Communications of the ACM, vol. 61, no. 11, pp. 114–123, Nov. 2018.
  • [10] M. Björklund, “A YANG Data Model for Interface Management,” RFC 8343, Mar. 2018.
  • [11] A. Bierman and M. Björklund, “A YANG Data Model for System Management,” RFC 7317, Aug. 2014.
  • [12] jetconf architecture - gitlab. [Online]. Available: https://gitlab.labs.nic.cz/labs/jetconf/wikis/jetconf-architecture
  • [13] restconf openwrt. [Online]. Available: https://gitlab.labs.nic.cz/labs/jetconf/wikis/restconf-openwrt
  • [14] Opendaylight controller:md-sal:explained - opendaylight project. [Online]. Available: https://wiki.opendaylight.org/view/OpenDaylight_Controller:MD-SAL:Explained
  • [15] [Online]. Available: https://openwrt.org/packages/pkgdata/jamvm
  • [16] clicon/clixon: Clixon automatically generates interactive cli, netconf, restconf and embedded databases with transaction support from a yang specification. [Online]. Available: https://github.com/clicon/clixon
  • [17] D. Robinson and K. Coar, “The Common Gateway Interface (CGI) Version 1.1,” RFC 3875, Oct. 2004.
  • [18] Openwrt project: Supported devices. [Online]. Available: https://openwrt.org/supported_devices