A Two-Stage Approach towards Generalization in Knowledge Base Question Answering
Abstract
Most existing approaches for Knowledge Base Question Answering (KBQA) focus on a specific underlying knowledge base either because of inherent assumptions in the approach, or because evaluating it on a different knowledge base requires non-trivial changes. However, many popular knowledge bases share similarities in their underlying schemas that can be leveraged to facilitate generalization across knowledge bases. To achieve this, we introduce a KBQA framework based on a 2-stage architecture that explicitly separates semantic parsing from the knowledge base interaction, facilitating transfer learning across datasets and knowledge graphs. We show that pretraining on datasets with a different underlying knowledge base can nevertheless provide significant performance gains and reduce sample complexity. Our approach achieves comparable or state-of-the-art performance for LC-QuAD (DBpedia), WebQSP (Freebase), SimpleQuestions (Wikidata) and MetaQA (Wikimovies-KG).
1 Introduction
Knowledge Base Question Answering (KBQA) has gained significant popularity in recent times due to its real-world applications, facilitating access to rich Knowledge Graphs (KGs) without the need for technical query-syntax. Given a natural language question, a KBQA system is required to find an answer based on the facts available in the KG. For example, given the question “Who is the director of the film Titanic", a KBQA system should retrieve the entity corresponding to “James Cameron". This would be dbr:James_Cameron11 1 dbr: http://dbpedia.org/resource/ in DBpedia (Auer et al. 2007), wd:Q4257422 2 wd: http://www.wikidata.org/entity in Wikidata (Vrandečić and Krötzsch 2014), and fb:m.03_gd33 3 fb: http://rdf.freebase.com/ns/ in Freebase (Bollacker et al. 2008).
KBQA has been evaluated on multiple different KGs such as Freebase (Bollacker et al. 2008), Wikidata (Vrandečić and Krötzsch 2014), DBpedia (Auer et al. 2007), and MetaQA (Zhang et al. 2018). Most existing heuristic-based KBQA approaches such as NSQA (Kapanipathi et al. 2020), gAnswer (Zou et al. 2014), and QAmp (Vakulenko et al. 2019) are typically tuned for a specific underlying knowledge base making it non-trivial to generalize and adapt it to other knowledge graphs. On the other hand, WDAqua (Diefenbach, Singh, and Maret 2017), a system with a focus on being generalizable, ignores question syntax, thereby showing reduced performance on datasets with complex multi-hop questions.
Recently, there has been a surge in end-to-end learning approaches that are not tied to specific KGs or heuristics, and hence can generalize to multiple KGs. GrailQA (Gu et al. 2021) in particular categorized different forms of generalization, such as novel relation compositionality and zero-shot generalization. They also demonstrated transfer across QA datasets, but within the same KG. On the other hand, GraftNet (Sun et al. 2018) and EmbedKGQA (Saxena, Tripathi, and Talukdar 2020) demonstrated their ability to generalize over multiple KGs by demonstrating state-of-the-art performance on MetaQA (Wikimovies) as well as WebQSP (Freebase). The two techniques, however, are highly sensitive to the training data; failing to generalize in terms of relation compositionality within a KG. EmbedKGQA and GraftNet show significant drops (between 23-50%) in performance on relation compositions that are not seen during training. Furthermore, it is unclear how these systems transfer across KGs because of their tight-integration with KG-specific embeddings.
In this work, we present a novel generalizable KBQA approach STaG-QA (Semantic parsing for Transfer and Generalization) that works seamlessly with multiple KGs, and demonstrate transfer even across QA datasets with different underlying KGs. Our approach attempts to separate aspects of KBQA systems that are softly tied to the KG but generalizable, from the parts more strongly tied to a specific KG. Concretely, our approach has two stages: 1) The first stage is a generative model that predicts a query skeleton, which includes the query pattern, the different sparql operators in it, as well as partial relations based on label semantics that can be generic to most knowledge graphs. 2) The second stage converts the output of the first stage to a final query that includes entity and relations mapped to a specific KG to retrieve the final answer.
Our contributions are as follows:
- •
A simple Seq2Seq architecture for KBQA that separates aspects of the output that are generalizable across KGs, from those that are strongly tied to a specific KG.
- •
To the best of our knowledge, our approach is the first to evaluate on and achieve state-of-the-art or comparable performance on KBQA datasets corresponding to four different knowledge graphs, i.e, LC-QuAD (DBpedia), WebQSP (Freebase), SimpleQuestions (Wikidata) and MetaQA (Wikimovies).
- •
Our extensive experimental results shows that the proposed architecture: (a) facilitates transfer with significant performance gains in low-resource setting; (b) generalizes significantly better (23-50%) to unseen relation combinations in comparison to state-of-the-art approaches.
2 Proposed Architecture
The KBQA task involves finding an answer for a natural language question from a given KG. Following the semantic parsing techniques for KBQA (Chen et al. 2021; Kapanipathi et al. 2020; Yih et al. 2015), we attempt to solve this task by predicting the correct structured sparql query that can retrieve the required answer(s) from the KG, i.e, by estimating a probability distribution over possible sparql queries given the natural language question.
In this work, we aim to design a model architecture that generalises across different KGs such as DBpedia, Wikidata, and Freebase. In order to achieve this goal, we have a 2-stage approach as shown in Figure 1, where we separate generic sparql query-sketch learning from KG-specific mapping of concepts. Specifically, the following 2-stages are:
- •
Softly-tied query sketch: This is the first stage of our approach where we intend to learn aspects of the sparql query generation that are generic to any knowledge graph. Specifically, we observe the following: (i) multi-hop patterns are mostly generic to question answering over KGs. (ii) across many KGs, analogous relations have semantic or lexical overlap. Therefore, we focus on 2 sub-tasks in this stage, query skeleton generation and partial relation linking. We call the output of this stage a softly-tied semantic parse, because the exact output is partially dependent on the specific KG in use, but our choice of representations and architecture ensures that transfer across KGs is a natural consequence.
- •
KG alignment: This is the next step where we introduce all vocabulary specific to the knowledge graph in order to generate an executable sparql query. To do so, we bind the softy-tied semantic parse strongly to the KG to find the answer by (i) resolving the textual relations to KG relations, (ii) introducing KG specific entities into the sparql skeleton, and (iii) rank the obtained sparql queries based on its groundings in the KG.
| KG | Query Graph Structure |
|---|---|
| DBpedia |
?var <director> <entity> ?var <language> ?ans |
| Wikimovies |
?var <directed by> <entity> ?var <In language> ?ans |
| Wikidata |
?var <director> <entity>
?var <original language
of film> ?ans
|
2.1 Softly-tied Query Sketch
As mentioned above, the goal is to create a representation and architecture that can generalize easily not only across examples within a dataset, but also across KGs. To accomplish this, we define 2 subtasks: (a) Skeleton Generation, and (b) Partial relation linking.
Skeleton Generation:
A sparql’s skeleton captures the operators needed to answer the question; i.e. ask, select, count or filter, as well as the query graph structure, with placeholder nodes for entities (e.g. :ent0), relations (e.g. :prop0) and variables (e.g. ?var0). For many questions, the generated sparql skeletons across different KGs are similar, if not identical. The skeleton structures unique to a KG, e.g. reification (present in Wikidata but not DBpedia), can be learnt when fine-tuning on a dataset with that underlying KG. An example of a sparql skeleton for our running example in Figure 1 “The films directed by John Krasinski are in which language?" is:
As shown in Figure 1, the question is passed through a transformer-based Seq2Seq model which is trained to produce the sparql skeleton corresponding to the question text. The encoder of the Seq2Seq model is a bi-direction transformer, while the decoder is auto-regressive with a causal self-attention mask.
Given a question text, we tokenize it using BERT tokenizer and add special [CLS] and [SEP] symbols in the beginning and the end of the question, respectively. This tokenized input is passed through a transformer encoder, producing encoder hidden states for each token at each layer. The encoder is initialized with pretrained BERT model (Devlin et al. 2018), which helps generalization with respect to different question syntax.
We then use a transformer decoder with cross attention mechanism. At each time step , the decoder considers the encoder states via cross-attention and previous decoder states via self attention. It produces a distribution over possible skeleton output tokens. The decoder output vocabulary comprises of entity place holder tokens , relation place holder tokens and sparql operators ; each of these is a small closed set of tokens. The output of each decoding step is a softmax over possible operators . Unlike the encoder, no pre-trained model is used for the decoder, and paramerters are initialized randomly.
Partial Relation Linking: For each relation placeholder in the sparql skeleton (:prop0, :prop1, etc), we need to identify the appropriate relation that can replace the placeholder to produce the correct semantic representation of the query. We have noted previously that relations across KGs share lexical and semantic similarities. For example, in Table 1 the three KGs (DBpedia, Wikimovies, and Wikidata) represent the relationship “Directed by" with very similar lexical terms “Director" and “Directed by". We can thus leverage large pre-trained language models to allow generalization and transfer of such relations across KGs. In each KG, we first map the relations to their respective surface forms, using either label relations from the KG, or by extracting some semantically meaningful surface form from the relation URI. These are the “textualized relations" shown in Figure 1. Table 2 shows some more examples of relation labels for 3 KGs. Note that this mapping can be many-to-one. For example, both dbo:language and dbp:language map to the same relation label “language".
| KG | KG Relation | Derived Surface Form |
| DBpedia | dbo:language | language |
| dbp:language | language | |
| dbp:languages | languages | |
| Wikidata | P397 | official language |
| P364 | original language of film or TV show | |
| FreeBase | people.ethnicity.languages_spoken | languages spoken |
| location.country.languages_spoken | languages spoken |
Our goal is to identify which relation surface form best matches each relation placeholder in the skeleton. We thus train the Seq2Seq decoder and relation encoder to project into the same space. Concretely, the decoder hidden state corresponding to each relation placeholder is optimised to be closest to the encoded representation of the correct relation, using a cross-entropy loss. For example, in Figure 1, the decoder state for :prop0 should have maximum inner product with the encoded representation for the relation surface form “Directed by", compared to the encoded representations of all other relations. Our relation encoder is a transformer model whose parameters are initialized with pretrained BERT model. Given that BERT-based representations of lexically or semantically similar relations across KGs will be close, it is easy to see why transfer across KG is possible. The final outcome of partial relation linking is a ranked list of relation surface forms for each placeholder in the skeleton.
The skeleton generation loss and partial relation linking loss are optimized jointly. The sparql skeleton together with the partial relation linking produces a ranked list of softly-tied query sketches. In the case of multiple placeholders, the score of each pair of relation surface forms is the product of their individual scores. Sometimes this phase produces multiple semantic interpretations, either due to noisy surface forms (for instance, DBpedia KG includes Wikipedia infobox keys “as is” when they can not be mapped to the ontology relations) or due to the presence of semantically identical or similar relations with distinct identifiers (eg. dbo:language and dbp:language). For the example, “The films directed by John Krasinski are in which language?", this stage will produce the following sketches:
2.2 KG Interaction
In order to generate an executable sparql query, we need to introduce vocabulary specific to the KG. The KG interaction stage performs this task. Concretely, given a list of candidate query sketches, this stage performs the following steps to produce the final question answer: 1) link the different entities to their corresponding placeholders in the skeleton, 2) disambiguate relations’ textual form and link it to the specific KG relations, and 3) select the correct sparql based on the actual facts in the KG.
In our approach, we leverage a pre-trained off-the-shelf entity linker, BLINK (Wu et al. 2020). BLINK provides tuples of (surface form, linked entity) pairs. The entity placeholder resolution step aligns the entities with the entity place holders in the query sketch. In the example above, :ent0 will be linked to dbr:John_Krasinski in DBpedia, or wd:Q313039 in Wikidata. When multiple entities are present in the question, the position of the corresponding textual span defines the alignment to the entity placeholder variable. During training, the first entity in the question corresponds to :ent0, the second entity by :ent1, etc. This pattern is repeated by the system when decoding during inference, making entity placeholder resolution trivial.
The next step is to disambiguate relations’ textual form and link them to the specific KG relations. Recall from Table 2 that each surface form in a query sketch can map to one or more KG relations. In our example using DBpedia as a KG, the surface form “director" could map to both [dbo:director, dbp:director] whereas “language" could map to both [dbo:language, dbp:language]. The semantic parsing stage cannot hope to distinguish between these, and thus we rely on the KG to determine the specific relation that should be chosen. Concretely, we replace every relation surface form with each of the possible KG relations it could map to. Thus, each softly-tied query sketch produces one or more fully executable sparqls. For example, the 2 softly-tied sketches from the previous stage in our example produce 4 possible sparqls, see Table 3. As the final step, we execute the candidate sparql queries against the KB and choose the highest-ranked sparql that produces an answer for select queries. Since ask queries do not necessarily have to be valid in the KG, we only consider the model score in such cases.
| Rank | Predicted SPARQL Query |
|---|---|
| 1 |
SELECT ?var0 where {
?var1 dbo:director dbr:John_Krasinski.
?var1 dbo:language ?var0. }
|
| 1 |
SELECT ?var0 where {
?var1 dbp:director dbr:John_Krasinski.
?var1 dbo:language ?var0. }
|
| 2 |
SELECT ?var0 where {
?var1 dbo:director dbr:John_Krasinski.
?var1 dbp:languages ?var0. }
|
| 2 |
SELECT ?var0 where {
?var1 dbp:director dbr:John_Krasinski.
?var1 dbp:languages ?var0. }
|
3 Experiments
In this section, we compare STaG-QA to other state-of-the-art approaches on datasets from multiple KGs. We validate 2 claims: (1) STaG-QA achieves state-of-the-art or comparable performance on a variety of datasets and KGs. (2) STaG-QA generalizes across KBs and hence facilitating transfer. The results show that pre-training our system achieves improvement in performance with better gains in low-resource and unseen relation combination settings.
| KG | Train | Valid | Test | |
|---|---|---|---|---|
| LC-QuAD 1.0 | DBpedia | 3,650 | 200 | 1,000 |
| SimpleQuestion | Wikidata | 15,000 | 2,000 | 2,280 |
| WQSP-FB | Freebase | 2898 | 200 | 1,596 |
| MetaQA 1-hop | Wikimovies | 86,470 | 9,992 | 9,947 |
| MetaQA 2-hop | Wikimovies | 118,980 | 14,872 | 14,872 |
| MetaQA 3-hop | Wikimovies | 114,196 | 14,274 | 14,274 |
3.1 Datasets
To evaluate the generality of our approach, we used datasets across a wide variety of KGs including Wikimovies-KG, Freebase (Bollacker et al. 2008), DBpedia (Auer et al. 2007), and Wikidata (Vrandečić and Krötzsch 2014). In particular, we used the following datasets (Table 4 shows detailed statistics for each dataset): (a) MetaQA (Wikimovies-KG) (Zhang et al. 2018) is a large-scale complex-query answering dataset on a KG with 135k triples, 43k entities, and nine relations. It contains more than 400K questions for both single and multi-hop reasoning. (b) WQSP-FB (Freebase) (Yih et al. 2016) provides a subset of WebQuestions with semantic parses, with 4737 questions in total. (c) LC-QuAD 1.0 (DBpedia) (Trivedi et al. 2017): A dataset with 5,000 questions (4,000 train and 1,000 test) based on templates. It includes simple, multi-hop, as well as aggregation-type questions. LC-QuAD 2.0 is another version of LC-QuAD based on Wikidata. It has 30K question in total and also template-based. Due to the larger underlying KB and the extensive pattern covered, we used LC-QuAD 2.0 dataset for pretraining and showing our transfer results. (d) SimpleQuestions-Wiki (Wikidata) (Diefenbach et al. 2017): a mapping of the popular Freebase’s SimpleQuestions dataset to Wikidata KB with 21K answerable questions.
3.2 Baselines
In this work, we evaluate against 8 different KBQA systems categorized into unsupervised (Kapanipathi et al. 2020; Sakor et al. 2020; Vakulenko et al. 2019; Diefenbach, Singh, and Maret 2017) and supervised approaches (Sun et al. 2020; Maheshwari et al. 2019; Saxena, Tripathi, and Talukdar 2020; Sun, Bedrax-Weiss, and Cohen 2019; Sun et al. 2018). 1) NSQA (Kapanipathi et al. 2020; Abdelaziz et al. 2021) is state-of-the-art system for KBQA on DBpedia datasets. 2) QAMP (Vakulenko et al. 2019) is an unsupervised message passing approach that provides competitive performance on LC-QuAD 1.0 dataset. (3) WDAqua (Diefenbach, Singh, and Maret 2017) is another system that generalises well across a variety of knowledge graphs. (4) Falcon 2.0 (Sakor et al. 2020) is a heuristics-based approach for joint detection of entities and relations in Wikidata. Since this approach does not predict the query structure, we tested it on SimpleQuestions dataset only. (5) EmbedKGQA (Saxena, Tripathi, and Talukdar 2020) is the state-of-the-art KBQA system on MetaQA and WebQSP datasets, (6) PullNet (Sun, Bedrax-Weiss, and Cohen 2019) is recent approach evaluated on MetaQA and WebQSP datasets, (7) GraftNet (Sun et al. 2018) infuses both text and KG into a heterogeneous graph and uses GCN for question answering, and (8) EmQL (Sun et al. 2020) is a query embedding approach that was successfully integrated into a KBQA system and evaluated on WebQSP and MetaQA datasets.
3.3 KBQA Evaluation
Table 5 shows our system results on all four datasets in comparison to existing approaches. We show two versions of our system, one pre-trained with LC-QuAD 2.0 datatset (Dubey et al. 2019) (STaG-QApre) and another trained from scratch on the target dataset only (STaG-QA). As noted earlier, to the best of our knowledge, we are the first to show generality across knowledge graphs by evaluating on datasets from DBpedia, Wikidata, Freebase, and Wikimovies-KG.
Our approach achieves significantly better performance compared to Falcon 2.0 on SimpleQuestions-Wiki dataset with 24% better F1 score. While Falcon 2.0 is not a KBQA system itself, it jointly predicts entities and relations given a question. Since SimpleQuestions-Wiki requires only a single entity and a single relation, we used Falcon 2.0 output to generate the corresponding sparql query required for KBQA evaluation. On MetaQA dataset, our system as well as the baselines achieve near perfect scores indicating the simplicity of this dataset.
On LC-QuAD 1.0, our approach significantly outperforms existing DBpedia-based approaches. When pretrained on LC-QuAD 2.0, the performance is 9% better F1 compared to NSQA; the state-of-the-art system on DBpedia. The large improvement indicates that STaG-QA was able to generalize and learn similar patterns between LC-QuAD 1.0 and LC-QuAD 2.0. As for WebQSP, both versions of our approach are inferior compared to EmQL. However, it is also worth noting that EMQL also leverages KBC embeddings, which is not currently utilized STaG-QAȮverall, the results show that STaG-QA shows better or competitive performance on 3 out of four datasets and when pretrained on another dataset, the performance improves across all datasets. In the next section, we analyze different datasets in terms of the degree of challenge they pose for KBQA systems. We propose evaluation splits that will allow us to better discriminate different systems in terms of their performance on these datasets.
| SimpleQuestions-Wiki | LC-QuAD 1.0 | WebQSP | MetaQA | |||||||||||||
| System | P | R | F1 | P | R | F1 | Hits@1 |
|
|
| ||||||
| WDAqua | - | - | - | 22.0 | 38.0 | 28.0 | - | - | - | - | ||||||
| QAMP | - | - | - | 25.0 | 50.0 | 33.0 | - | - | - | - | ||||||
| NSQA | - | - | - | 44.8 | 45.8 | 44.4 | - | - | - | - | ||||||
| Falcon 2.0 | 34 | 41.1 | 36.3 | - | - | - | - | - | - | - | ||||||
| GraftNet | - | - | - | - | - | - | 70.3 | 97.0 | 99.9 | 91.4 | ||||||
| PullNet | - | - | - | - | - | - | 69.7 | 97.0 | 99.9 | 91.4 | ||||||
| EmbedKGQA | - | - | - | - | - | - | 66.6 | 97.5 | 98.8 | 94.8 | ||||||
| EMQL | - | - | - | - | - | - | 75.5 | - | 98.6 | 99.1 | ||||||
| STaG-QA | 59.4 | 62.7 | 61.0 | 76.5 | 52.8 | 51.4 | 65.9 | 100.0 | 100.0 | 99.9 | ||||||
| STaG-QApre | 60.2 | 63.2 | 61.7 | 74.5 | 54.8 | 53.6 | 68.5 | 100.0 | 100.0 | 100.0 | ||||||
3.4 Effect of Pretraining
Our architecture is designed to allow transfer learning between entirely different QA dataset/KG pairs. As it is harder to show improvements with pre-training on larger datasets, we consider low-resource settings to demonstrate the benefit of transfer, even across KGs. This is useful when there is scarcity of training data for a new target KG. We investigate the benefit of pretraining the semantic parsing stage using LC-QuaD 2.0 (Wikidata KG), before training on the 2-hop dataset in MetaQA (MetaQA-KG) and the LC-QuAD 1.0 dataset (DBpedia). Figures 2 and 3 show the performance of STaG-QA on each dataset with and without pre-training. We make note of the following observations. First, without any fine-tuning on either datasets, the pre-trained version STaG-QApre was able to achieve 18% Hits@1 on MetaQA and 8% F1 on LC-QuAD 1.0, indicating the model ability to do zero-shot transfer across knowledge graphs. Second, the pre-trained version provides better performance and is able to converge much faster. For example, in MetaQA (Figure 2), STaG-QApre was able to reach almost 100% Hits@1 with 100 training examples only. To reach the same 100% Hits@1, STaG-QA without pretraining required 1,000 examples, an order of magnitude more training data. The same behaviour can be observed on LC-QuAD 1.0, where STaG-QApre is better than STaG-QA, but with both versions continuing to improve as more training data becomes available.
3.5 Generalization to novel relation composition
Common KBs have a large number of relations. For example, DBpedia (v2016-10) has around 60K relations, Wikidata (as of March 2020) has 8K relations, whereas Freebase contains 25K relations. In multi-hop queries, these relations can be arranged as paths (e.g., director language) where possible path combinations grow combinatorially. With learning-based approaches, seeing all or most possible relation combinations at training would indeed result in performance improvement at the testing phase. However, this is impractical and hard to enforce in practical scenarios with most KBs as it would require significantly large training data to cover all combinations. Instead, an effective KBQA system should be able to generalise to unseen relation paths. In this section, we first analyse existing KBQA datasets to see to which extent this ability is being tested currently. We then create a development set specifically for testing the ability of KBQA systems to generalise to unseen multi-hop relation paths.
We show in Table 6 the number of test questions in LC-QuAD 1.0, MetaQA and WebQSP datasets that contain relation combinations never seen at training. For instance, MetaQA does not test for any unseen relation paths (0%) where WebQSP contains only 2.06% of such questions. In contrast, in LC-QuAD 1.0 roughly half of the test questions contain novel relation compositions.
| Dataset | # of questions with unseen paths |
|---|---|
| LC-QuAD 1.0 | 490/1,000 (49 %) |
| WebQSP | 45/1,638 (2 %) |
| MetaQA 2-hop | 0/14,872 (0 %) |
| MetaQA 3-hop | 0/14,274 (0 %) |
MetaQA Unseen Challenge Set:
In order to further investigate how this issue affects current KBQA systems, we created a subset from MetaQA, the largest dataset in Table 6 and yet having no unseen relation combinations at testing. We modified the train and dev sets of MetaQA as follows: From the 2-hop training set, we removed training examples containing two randomly chosen relation paths ( actor_to_movie_to_director and director_to_movie_to_actor) and split the dev set into two, one containing 13,510 questions with all seen relations path in training and another containing 1,361 questions with all unseen relation paths. It is important to note that for each of the unseen relation combinations, the individual relations are present in the training set, i.e, this experiment is designed to test compositionality rather than zero-shot relation linking ability.
| System | 2-Hop Seen | 2-hop Unseen |
|---|---|---|
| EmbedKGQA | 99.00 | 50.00 |
| GraftNet-KB | 97.90 | 75.2 |
| GraftNet-Text | 51.2 | 43.3 |
| GraftNet-Both | 99.13 | 95.41 |
| STaG-QA | 99.9 | 99.7 |
We then trained STaG-QA, EmbedKGQA and GraftNet on the new reduced training set and tested the performance on our new development sets (seen and unseen). Table 7 shows the results for each system on 2-hop questions on seen relation paths vs unseen ones. The results clearly demonstrate that there is a significant drop in performance in methods that rank directly across entities in the KG to predict answers. This is most clearly observed in EmbedKGQA, as well as GraftNet-KB, though the use of text (GraftNet-Text and GraftNet-Both) does alleviate this issue. In contrast, our approach is able to maintain exactly the same level of performance for novel relation compositions using KB information alone.
4 Related Work
There have been a wide variety of Knowledge Base Question Answering (KBQA) systems (Chen et al. 2020; Saxena, Tripathi, and Talukdar 2020; Maheshwari et al. 2019; Zou et al. 2014; Diefenbach, Singh, and Maret 2017; Vakulenko et al. 2019; Kapanipathi et al. 2020), trained on datasets that are either question-sparql pairs (strong supervision) or question-answer pairs (weak supervision). More generally, the former can use any logical form that expresses the question as an RDF-query, which is then run on the KG to retrieve the answer. We describe some KBQA systems in this section.
As mentioned above, the first category of KBQA approaches focus on translating the natural language questions into an intermediate logical form to retrieve results from the knowledge base. Generating this kind of semantic parse of the question has shown improved performance compared to weak-supervision based approaches (Yih et al. 2016). Furthermore, the intermediate structured representation of the question provides a level of interpretability and explanation that is absent in systems that directly rank over entities in the KG to produce answers. This category can further be classified into (a) rule-based approaches such as gAnswer (Hu et al. 2017), NSQA (Kapanipathi et al. 2020), and (b) learning-based approaches such as MaSP (Shen et al. 2019) and GrailQA (Gu et al. 2021).
The rule based approaches primarily depend on generic language based syntactic (Zou et al. 2014) or semantic parses (Abdelaziz et al. 2021; Kapanipathi et al. 2020) of the question and build rules on it to obtain a query graph that represents the sparql query. NSQA, the state of the art approach for DBpedia based datasets such as LC-QuAD-1.0 (Trivedi et al. 2017) and QALD-9 (Usbeck et al. 2017), falls in this category. The system uses Abstract Meaning Representation (AMR) parses of the question and a heuristic-based graph-driven methodology to transform the AMR graph to a query graph that represents the sparql query. Many of these systems have components or aspects that are specific to the KG they evaluate on, and do not trivially generalize to other KGs. In particular GAnswer, NSQA, and QAmp are specific to DBpedia and do not evaluate their approaches on any other KGs.
On the other hand, MaSP is a multi-task end-to-end learning approach that focuses of dialog-based KGQA setup. MaSP uses a predicate classifier which makes transfer across KGs non-trivial. We adapt the architecture to make it generalizable across KGs, by replacing the relation classifier with a BERT-based ranker that leverages similarities in label semantics between KGs. A prominent work, Krantikari (Maheshwari et al. 2019) is on regular KBQA and has a ranking based approach that is heavily dependent on the knowledge graph. The approach ranks all candidate graph patterns retrieved from the knowledge graph based on the grounded entity. In multi-hop settings, as in MetaQA with 3-hop questions, retrieving all possible candidates upto -hops (for an arbitrary choice of ) and then ranking across all of them is expensive. In contrast, our work focuses on a generative approach to modeling query graph patterns. GrailQA is an end-to-end learning approach that generates logical S-forms. It characterizes a few forms of generalization such as compositionality and zero-shot generalization. It also introduces a method that transfers across QA datasets, but within the same KG. On the other hand, we demonstrate transfer across KGs.
The final category of KBQA approaches are trained solely with question-answer pairs ignoring the intermediate logical representation of the question. EmbedKGQA (Saxena, Tripathi, and Talukdar 2020) and GraftNet are two such approaches that directly ranks across entities in the knowledge base to predict an answer, by leveraging either KG embeddings from Knowledge Base Completion (KBC); or creating a unified graph from KB and text. However, these approaches do not generalize well to novel relation compositions not seen during training. Finally, it is unclear how to transfer KBC embedding-based approaches such as EmbedKGQA across KGs since the learnt KG embeddings are tightly coupled with the specific KG in question.
5 Conclusion
In this work, we show that a simple 2-stage architecture which explicitly separates the KG-agnostic semantic parsing stage from the KG-specific interaction can generalize across a range of datasets and KGs. We evaluated our approach on four different KG/QA pairs, obtaining state-of-the-art performance on MetaQA, LC-QuAD 1.0, and SimpleQuestions-Wiki; as well as competitive performance on WebQSP. Furthermore, we successfully demonstrate transfer learning across KGs by showing that pre-training the semantic parsing stage on an existing KG/QA-dataset pair can help improve performance in low-resource settings for a new target KG; as well as greatly reduce the number of examples required to achieve state-of-the-art performance. Finally, we show that some popular benchmark datasets do not evaluate generalization to unseen combinations of seen relations (compositionality), an important requirement for a question answering system.
References
- Abdelaziz et al. (2021) Abdelaziz, I.; Ravishankar, S.; Kapanipathi, P.; Roukos, S.; and Gray, A. 2021. A semantic parsing and reasoning-based approach to knowledge base question answering. In Proceedings of the AAAI Conference on Artificial Intelligence, volume 35, 15985–15987.
- Auer et al. (2007) Auer, S.; Bizer, C.; Kobilarov, G.; Lehmann, J.; Cyganiak, R.; and Ives, Z. 2007. Dbpedia: A nucleus for a web of open data. In The semantic web, 722–735. Springer.
- Bollacker et al. (2008) Bollacker, K.; Evans, C.; Paritosh, P.; Sturge, T.; and Taylor, J. 2008. Freebase: a collaboratively created graph database for structuring human knowledge. In Proceedings of the 2008 ACM SIGMOD international conference on Management of data, 1247–1250.
- Chen et al. (2021) Chen, S.; Liu, Q.; Yu, Z.; Lin, C.-Y.; Lou, J.-G.; and Jiang, F. 2021. ReTraCk: A Flexible and Efficient Framework for Knowledge Base Question Answering. In Proceedings of the 59th Annual Meeting of the Association for Computational Linguistics and the 11th International Joint Conference on Natural Language Processing: System Demonstrations, 325–336. Online: Association for Computational Linguistics.
- Chen et al. (2020) Chen, Y.; Li, H.; Hua, Y.; and Qi, G. 2020. Formal Query Building with Query Structure Prediction for Complex Question Answering over Knowledge Base. In International Joint Conference on Artificial Intelligence (IJCAI).
- Devlin et al. (2018) Devlin, J.; Chang, M.-W.; Lee, K.; and Toutanova, K. 2018. Bert: Pre-training of deep bidirectional transformers for language understanding. arXiv preprint arXiv:1810.04805.
- Diefenbach, Singh, and Maret (2017) Diefenbach, D.; Singh, K.; and Maret, P. 2017. Wdaqua-core0: A question answering component for the research community. In Semantic Web Evaluation Challenge, 84–89. Springer.
- Diefenbach et al. (2017) Diefenbach, D.; Tanon, T. P.; Singh, K. D.; and Maret, P. 2017. Question Answering Benchmarks for Wikidata. In Proceedings of the ISWC 2017 Posters & Demonstrations and Industry Tracks co-located with 16th International Semantic Web Conference (ISWC 2017), Vienna, Austria, October 23rd - to - 25th, 2017.
- Dubey et al. (2019) Dubey, M.; Banerjee, D.; Abdelkawi, A.; and Lehmann, J. 2019. Lc-quad 2.0: A large dataset for complex question answering over wikidata and dbpedia. In International semantic web conference, 69–78. Springer.
- Gu et al. (2021) Gu, Y.; Kase, S.; Vanni, M.; Sadler, B.; Liang, P.; Yan, X.; and Su, Y. 2021. Beyond IID: three levels of generalization for question answering on knowledge bases. In Proceedings of the Web Conference 2021, 3477–3488.
- Hu et al. (2017) Hu, S.; Zou, L.; Yu, J. X.; Wang, H.; and Zhao, D. 2017. Answering natural language questions by subgraph matching over knowledge graphs. IEEE Transactions on Knowledge and Data Engineering, 30(5): 824–837.
- Kapanipathi et al. (2020) Kapanipathi, P.; Abdelaziz, I.; Ravishankar, S.; Roukos, S.; Gray, A.; Astudillo, R.; Chang, M.; Cornelio, C.; Dana, S.; Fokoue, A.; et al. 2020. Question Answering over Knowledge Bases by Leveraging Semantic Parsing and Neuro-Symbolic Reasoning. arXiv preprint arXiv:2012.01707.
- Maheshwari et al. (2019) Maheshwari, G.; Trivedi, P.; Lukovnikov, D.; Chakraborty, N.; Fischer, A.; and Lehmann, J. 2019. Learning to rank query graphs for complex question answering over knowledge graphs. In International semantic web conference, 487–504. Springer.
- Sakor et al. (2020) Sakor, A.; Singh, K.; Patel, A.; and Vidal, M.-E. 2020. Falcon 2.0: An entity and relation linking tool over Wikidata. In Proceedings of the 29th ACM International Conference on Information & Knowledge Management, 3141–3148.
- Saxena, Tripathi, and Talukdar (2020) Saxena, A.; Tripathi, A.; and Talukdar, P. 2020. Improving multi-hop question answering over knowledge graphs using knowledge base embeddings. In Proceedings of the 58th Annual Meeting of the Association for Computational Linguistics, 4498–4507.
- Shen et al. (2019) Shen, T.; Geng, X.; Qin, T.; Guo, D.; Tang, D.; Duan, N.; Long, G.; and Jiang, D. 2019. Multi-task learning for conversational question answering over a large-scale knowledge base. arXiv preprint arXiv:1910.05069.
- Sun et al. (2020) Sun, H.; Arnold, A. O.; Bedrax-Weiss, T.; Pereira, F.; and Cohen, W. W. 2020. Faithful Embeddings for Knowledge Base Queries. arXiv:2004.03658.
- Sun, Bedrax-Weiss, and Cohen (2019) Sun, H.; Bedrax-Weiss, T.; and Cohen, W. W. 2019. Pullnet: Open domain question answering with iterative retrieval on knowledge bases and text. arXiv preprint arXiv:1904.09537.
- Sun et al. (2018) Sun, H.; Dhingra, B.; Zaheer, M.; Mazaitis, K.; Salakhutdinov, R.; and Cohen, W. W. 2018. Open Domain Question Answering Using Early Fusion of Knowledge Bases and Text. EMNLP.
- Trivedi et al. (2017) Trivedi, P.; Maheshwari, G.; Dubey, M.; and Lehmann, J. 2017. LC-QuAD: A corpus for complex question answering over knowledge graphs. In ISWC 2017, 210–218.
- Usbeck et al. (2017) Usbeck, R.; Ngomo, A.-C. N.; Haarmann, B.; Krithara, A.; Röder, M.; and Napolitano, G. 2017. 7th open challenge on question answering over linked data (QALD-7). In Semantic Web Evaluation Challenge, 59–69. Springer.
- Vakulenko et al. (2019) Vakulenko, S.; Fernandez Garcia, J. D.; Polleres, A.; de Rijke, M.; and Cochez, M. 2019. Message passing for complex question answering over knowledge graphs. In Proceedings of the 28th ACM International Conference on Information and Knowledge Management, 1431–1440.
- Vrandečić and Krötzsch (2014) Vrandečić, D.; and Krötzsch, M. 2014. Wikidata: a free collaborative knowledgebase. Communications of the ACM, 57(10): 78–85.
- Wu et al. (2020) Wu, L.; Petroni, F.; Josifoski, M.; Riedel, S.; and Zettlemoyer, L. 2020. Zero-shot Entity Linking with Dense Entity Retrieval. In EMNLP.
- Yih et al. (2015) Yih, S. W.-t.; Chang, M.-W.; He, X.; and Gao, J. 2015. Semantic parsing via staged query graph generation: Question answering with knowledge base.
- Yih et al. (2016) Yih, W.-t.; Richardson, M.; Meek, C.; Chang, M.-W.; and Suh, J. 2016. The value of semantic parse labeling for knowledge base question answering. In ACL, 201–206.
- Zhang et al. (2018) Zhang, Y.; Dai, H.; Kozareva, Z.; Smola, A.; and Song, L. 2018. Variational reasoning for question answering with knowledge graph. In Proceedings of the AAAI Conference on Artificial Intelligence, volume 32.
- Zou et al. (2014) Zou, L.; Huang, R.; Wang, H.; Yu, J. X.; He, W.; and Zhao, D. 2014. Natural language question answering over RDF: a graph data driven approach. In Proceedings of the 2014 ACM SIGMOD international conference on Management of data, 313–324.