跳到论文正文
W Papers独立论文阅读器 arXiv:2109.09475 论文正文 计算阅读时间 · 0%
引用这篇论文根据当前论文元数据生成,正式投稿前建议核对。

    
  
License: CC BY 4.0
arXiv:2109.09475v1 [cs.CL] 06 Sep 2021

Knowledge Graph Question Answering via SPARQL Silhouette Generation

Sukannya Purkayastha Note: Work done while the author was an intern at IBM Research    Saswati Dana    Dinesh Garg    Dinesh Khandelwal    G P Shrivatsa Bhargav
Abstract

Knowledge Graph Question Answering (KGQA) has become a prominent area in natural language processing due to the emergence of large-scale Knowledge Graphs (KGs). Recently Neural Machine Translation based approaches are gaining momentum that translates natural language queries to structured query languages thereby solving the KGQA task. However, most of these methods struggle with out-of-vocabulary words where test entities and relations are not seen during training time. In this work, we propose a modular two-stage neural architecture to solve the KGQA task. The first stage generates a sketch of the target SPARQL called SPARQL silhouette for the input question. This comprises of (1) Noise simulator to facilitate out-of-vocabulary words and to reduce vocabulary size (2) seq2seq model for text to SPARQL silhouette generation. The second stage is a Neural Graph Search Module. SPARQL silhouette generated in the first stage is distilled in the second stage by substituting precise relation in the predicted structure. We simulate ideal and realistic scenarios by designing a noise simulator. Experimental results show that the quality of generated SPARQL silhouette in the first stage is outstanding for the ideal scenarios but for realistic scenarios (i.e. noisy linker), the quality of the resulting SPARQL silhouette drops drastically. However, our neural graph search module recovers it considerably. We show that our method can achieve reasonable performance improving the state-of-art by a margin of 3.72%3.72\% F1 for the LC-QuAD-1 dataset. We believe, our proposed approach is novel and will lead to dynamic KGQA solutions that are suited for practical applications.

Introduction

In recent years, there is an increasing interest in the Knowledge Graph Question Answering (KGQA) (Diefenbach et al. 2018) task in Natural Language Processing community due to its applicability in various real life and practical business applications. Availability of large-scale knowledge graphs, such as Freebase (Bollacker et al. 2008), DBpedia (Lehmann et al. 2015), YAGO (Pellissier Tanon, Weikum, and Suchanek 2020), NELL (Mitchell et al. 2015), and Google’s Knowledge Graph (Steiner et al. 2012) made this possible. The KGQA task requires a system to answer a natural language question leveraging facts present in a given KB. Mainly two streams of approaches are followed by KGQA community (1) semantic parse based (2) information extraction based. In Semantic parsed based approach, the task can be accomplished by translating the natural language question into a structured query languages or logic form such as SPARQL, SQL, λ\lambda-DCS (Liang 2013), CCG (Zettlemoyer and Collins 2005), etc. Generated query is then executed over the given KG to finally arrive to the answer. Information extraction based approaches are primarily concerned with final answer but not intermediate logic form. In semantic parsed based approaches, main challenges in obtaining correct form of logic/SPARQL is getting the right structure along with specific entities and relations in the knowledge graph. Performance of existing off-the-shelf entity-relation linkers is not encouraging enough in KGQA dataset to adapt them in this task. Therefore, most of the state-of-art systems follow Pipeline-based approaches with inbuilt entity-relation linker. These pipeline based approaches  (Singh et al. 2018; Kapanipathi et al. 2020; Liang et al. 2021) are a popular way to handle questions that requires multiple entities and relations to answer a given question (Li et al. 2016; Usbeck et al. 2017; Trivedi et al. 2017). The error introduced by inbuilt linkers is a major bottleneck and reduces the overall pipeline performance.

Figure 1: A high level view of our proposed two stage neural architecture for KGQA.

With progress of neural network models, KGQA community aspires to perform the task by leveraging neural network. However to do so, we need large-scale training data which is a challenge. These challenges limit the applicability of Deep Neural Network (DNN) based approaches on KGQA task. Existing neural approaches however, are currently limited to answering questions that require single relation from KG (He and Golub 2016; Dai, Li, and Xu 2016; Hao et al. 2017; Lukovnikov, Fischer, and Lehmann 2019; Lukovnikov et al. 2017). Some neural approaches  (Maheshwari et al. 2019) assume a noise-free entity linker or they mainly focus on relation linking sub-task  (Yu et al. 2017).  Hao et al. 2017 follows information extraction based approaches and leverages universal KG information to arrive at the final answer more accurately. Cheng and Lapata 2018 develops a system based on sequence-to-tree model where logic is in the latent form and supervision is in the form of final answer entity. Advances of translating natural language query to structured languages using NMT models  (Yin, Gromann, and Rudolph 2021; Cai et al. 2017) is emerging in recent years. In case of KGQA task, these NMT based methods suffer from out-of-vocabulary words and there is no explicit provision to handle unseen entities/relations at test-time. However, we believe that the core challenges involved in performing KGQA task via NMT methods is not explored fully and there is a significant scope for further investigation. Motivated by these observations, in this paper, we propose a novel two-stage neural architecture (see Figure 1) to answer KG based questions that need multiple entities and relations to answer them.

The main contributions of this work are as follows:

  1. 1.

    In Stage-I, a sketch of SPARQL called SPARQL silhouette is generated for input question. A noise simulator is designed in this module to devise three different kinds of masking strategies to simulate varying levels of noise introduced in entity/relation linking process.

  2. 2.

    In Stage-II, a simple and novel BERT based neural graph search module (NGS) is proposed which corrects predicted relations in the SPARQL silhouette. Purpose of having this module is to overcome performance limitation that arises due to the weaknesses of entity/relation linker present in the first stage.

  3. 3.

    An ideal entity/relation linker having 100%100\% F1F_{1} score is simulated and shown that the quality of generated SPARQL silhouette is high – 83.08%83.08\% F1F_{1} for LC-QuAD-1 and 55.3%55.3\% Macro F1F_{1} QALD for QALD-9.

  4. 4.

    Realistic scenario is simulated and shown that as F1F_{1} of the linker goes down, quality of the resulting SPARQL silhouette drops drastically. Finally, integrating Stage-II module with Stage-I boosts the performance significantly and improves the SOTA by a margin of 3.72%3.72\% F1F_{1} for LC-QuAD-1 dataset.

Related Work

In the beginning KGQA task was centralized in two directions either semantic parsed based  (Unger et al. 2012; Berant et al. 2013; Reddy, Lapata, and Steedman 2014; Bast and Haussmann 2015; Abujabal et al. 2017) approaches or information retrieval based  (Bast and Haussmann 2015; Yao and Van Durme 2014; Dong et al. 2015). Most of the earlier semantic parsed based approaches used handcrafted rules. We limit our discussion only to end-to-end neural approaches.

Approach Question Unseen Intermediate Supervision
Complexity Entities Logic Form
(He and Golub 2016) Simple Yes Yes Strong
(Yin et al. 2016) Simple Yes No Strong
(Hao et al. 2017) Complex Yes No Strong
(Maheshwari et al. 2019) Complex No Yes Strong
(Cheng and Lapata 2018) Complex Yes Yes Weak
(Yin, Gromann, and Rudolph 2021) Complex No Yes Strong
Our Approach Complex Yes Yes Strong
Table 1: Comparison of our approach with other neural network-based approaches. 2n​d2^{nd} column represents whether the approach can handle simple/complex questions. 3r​d3^{rd} column represents whether the approach can handle the unseen entities or not. 4t​h4^{th} represents if the approach generates an intermediate logic form or not. 5t​h5^{th} column represents the type of supervision required to train the model; Strong means supervision using the manually annotated logical forms, whereas weak refers to supervision by providing only the correct denotations.

Deep Neural Network Based Approaches

With availability of large-scale datasets, DNN based techniques have made huge improvements in machine reading comprehension tasks (Nguyen et al. 2016; Rajpurkar et al. 2016; Joshi et al. 2017). This motivated NLP researchers to apply DNN technique to translate natural language question to structure database query languages  (Yu et al. 2018; Wang et al. 2020; Hosu et al. 2018; Choi et al. 2021). For KGQA, datasets like SimpleQuestions (Bordes et al. 2015; He and Golub 2016), where only one entity and one relation are required to answer a question, performance of DNN models is already approaching the upper bound (Petrochuk and Zettlemoyer 2018). To solve simple QA He and Golub 2016 use a char-level LSTM based encoder for the question and a char-level CNN to encode predicates/entities in KB. An attention based LSTM decoder is used to generate the topic entities and predicates. Whereas, to solve the complex KGQA task (Bao et al. 2016; Su et al. 2016; Trivedi et al. 2017; Dubey et al. 2019) it requires multiple KG facts. To answer complex questions, Hao et al. 2017 first identify a topic entity from the question using FreeBase API and collect its 2-hop neighbours as potential answers. A cross-attention based Neural Net encodes the question w.r.t candidate answer aspects. Then they rank the candidates with similarity score based ranker without generating any intermediate logic form. Whereas, Maheshwari et al. 2019 start with the gold entity in the question to generate the n-hop core chain of candidates. Then a bi-LSTM based slot matching model encodes the question and candidate core chains which are then ranked later. Cheng and Lapata 2018 use a bi-LSTM encoder and stack-LSTM decoder to generate logical forms with weak supervision.Recently NMT  (Vaswani et al. 2017; Bahdanau, Cho, and Bengio 2015) based methods have also been used to solve KGQA task where a seq2seq model (He and Golub 2016; Dai, Li, and Xu 2016; Hao et al. 2017; Liang et al. 2017; Cheng and Lapata 2018) converts the natural language question directly into a logic form. Yin, Gromann, and Rudolph 2021 use CNN based seq2seq models to generate SPARQL queries from natural language questions. Their vocabulary for sparql generation is limited to the entities/relations seen during training. However, their performance reduces drastically if the overlap of entities and relations in the training and test sets differ as seq2seq models suffers from out-of-vocabulary words. Table 1 shows the comparison of our approach with the neural network based previous approaches. To the best of our knowledge, our work is the first of its kind of solving KGQA task which considers multiple relations and used NMT method that handle out-of-vocabulary situation by designing noise simulator with masking strategy.

The KGQA Task

In KGQA, we are given a Knowledge Graph 𝒢\mathcal{G} comprising of an entity set ℰ\mathcal{E}, a relation set ℛ\mathcal{R}, and a set of knowledge facts ℱ\mathcal{F}. The knowledge facts are expressed in the form of triples; ℱ={⟨es,r,eo⟩}⊆ℰ×ℛ×ℰ\mathcal{F}=\{\langle e_{s},r,e_{o}\rangle\}\subseteq\mathcal{E}\times\mathcal{R}\times\mathcal{E}, where es∈ℰe_{s}\in\mathcal{E} is known as subject or head entity, eo∈ℰe_{o}\in\mathcal{E} is known as object or tail entity, and rr is a relation which connects these two entities. These entities (relations) form the nodes (edges) of the KG. The task now is to identify the subset of entities from ℰ\mathcal{E} that constitute the answer of a given question QQ in the natural language form. The most common family of approaches for the KGQA task is semantic parsing where, the given question QQ is first translated into an SPARQL query SS which is then executed over the KG so as to get the answer set. For developing a system to convert a question into the corresponding SPARQL query, we are given a set of training data {Qi,Si,Ai}i=1n\{Q_{i},S_{i},A_{i}\}_{i=1}^{n}, where QiQ_{i} is a question (in natural language text), SiS_{i} is the SPARQL query, and AiA_{i} is the answer set obtained by executing SiS_{i} on 𝒢\mathcal{G}. The proposed system consists of two stage neural modules. In the Stage-I, seq2seq module generates a SPARQL silhoutte with specific entities. Relations predicted in this module are corrected by the Stage-II, neural graph search module.

Stage-I: Seq2Seq Model

Sequence-to-sequence model have achieved state-of-the-art performance in machine translation  (Yin and Neubig 2017) task. Encoder-decoder architecture of seq2seq models can vary from RNN, CNN based to transformer models. Prior research shows  (Yin, Gromann, and Rudolph 2021) that CNN based seq2seq model performs best among these for translating natural language to SPARQL query. Our preliminary experimental results were consistent with this fact since the CNN based model performed the best. Hence, we moved ahead with the CNN based seq2seq model as our base model for Stage I. Figure 2 shows the architecture of Stage-I. An external entity/relation linker is used to detect surface form mentions of the entities/relations in the question text and linking the same to the underlying KG (DBpedia here). We designed a noise simulator for adapting the data to be in necessary format for seq2seq model.

Figure 2: A detailed architecture of Stage-I.

Noise Simulator

Purpose of designing noise simulator is twofold: (i) To simulate varying levels of noise in the entity/relation linking process (ii) To mask mentions and entities/relations in the question text and SPARQL.
[Need for Masking] Masking helps in two ways: (1) handling test entities/relations that are unseen during training (2) reducing vocabulary size as KGs contain a large number of entities and relations. A simple neural seq2seq model which translates natural language question into a SPARQL query will struggle to output some of the entities/relations during test time that are unseen during training time and hence will not be available in the output vocabulary. In the absence of linking and masking, our elementary experiments shows the performance of seq2seq model bo be very low with F1 score 16%~16\% which was expected.

Dataset Statistics Val Test
LC-QuAD-1 Entities (dbr) 52.352.3 46.846.8
Properties (dbp) 97.297.2 98.398.3
Ontologies (dbo) 96.596.5 94.694.6
QALD-9 Entities (dbr) 27.127.1 25.925.9
Properties (dbp) 0.00.0 16.916.9
Ontologies (dbo) 47.847.8 38.338.3
Table 2: % of the entities and relations in val and test sets that are available within train set’s gold SPARQLs.

This outcome is obvious given the statistics in Table 2 which captures percentage of entities and relations (i.e. properties and ontology in DBpedia) in validation and test sets that are available in the training set. This suggest that entity and relation linker is must for any neural model. Even if we use only neural models with perfect linkers, our SPARQL vocabulary dictionary will be over growing which becomes difficult to manage. To handle the situation of increasing SPARQL vocabulary dictionary, we need masking/tagging techniques to mask entities and relations.
[Scenario ‘A’: Noise-Free Linking] In this scenario, we simulate an entity and relation linker that has 100%100\% F1F_{1}. For this, we pick all entities/relations from the gold SPARQL and pretend as if they were the output of the linker (see Figure 7 in appendix). We begin with extracting all the entities and relations from the gold SPARQL using their prefixes (dbr for entities and dbp or dbo for relations). Next, we pick these entities and relations, and align the same with surface-form mention text in the given question. We observe that entities match exactly with substrings in the questions most of the time (e.g. Austin College in Figure 7 of the appendix). For relations, an exact match is not always possible, e.g., a given relation dbo:film is semantically best aligned to word movies in the question. We use pre-trained fastext embeddings (Bojanowski et al. 2017) to represent words and relation and compute cosine similarity between each word in the question and the given relation. The highest-scoring word is considered as the aligned word. After identifying mentions of entities/relations, we mask them in question text and the corresponding gold SPARQL query. This masked pair is subsequently supplied to the seq2seq module as a training example.
[Scenario ‘B’: Partly Noisy Linking] Purpose of this scenario is to allow partial noise in the entity/relation linking process. For this, we first feed the natural language question into an external entity/relation linker. The linker returns two things: (i) A set of surface form mentions for entities/relations in the question text, and (ii) Linked entities/relations for these mentions. We take linker’s output and find intersection of these entities/relations with the entities/relations present in the gold SPARQL. These common entities/relations are masked in the SPARQL query. Also, their corresponding surface forms are masked in the question text. In order to mask the surface forms in the question, we use exact match and string overlap based Jaccard similarity. Figure 8 in appendix illustrates this scenario.
[Scenario ‘C’: Fully Noisy Linking] Goal here is to simulate a completely realistic scenario where we rely entirely on an external entity/relation linker. For this, we feed input question to the entity/relation linker and get the suggested surface form mentions and linked entities/relations. We mask each of these suggested mentions using exact match and partial match. Corresponding SPARQL query’s entities and relations are also masked based on the suggestions. This scenario is depicted in Figure 3.

Figure 3: An illustrative example for Scenario ‘C’.

Convolutional Seq2Seq Model

The pair of masked question and SPARQL query obtained from the noise simulator, under any noise scenario, is fed to a Convolutional Neural Network (CNN) based seq2seq model (Gehring et al. 2017). As shown in Figure 4, this model reads the entire masked question and then predicts the corresponding masked SPARQL query token-by-token in a left-to-right manner. This seq2seq model consists of the following key components.


Figure 4: A CNN-based Seq2Seq model for KGQA. We have assumed noise-free linking scenario here.

Figure 5: Architecture of neural graph search module. (a) Relation Classifier. This module predicts relation for a given entity (b) Ontology Type Classifier. This module predicts rdf:type ontology class.

[Input Embedding Layer] Both encoder and decoder consist of an embedding layer that maps each input token to a point-wise summation of its word embedding and positional embedding. The embedding of each word is initialized randomly. In order to capture the sense of order, the model is provisioned with the positional embedding.
[Convolution + Pooling Layers] The token embeddings obtained from the previous layer are fed to the multiple convolution and pooling layers. Each convolution layer consists of a 11-dimensional convolution followed by Gated Linear Units (GLU) (Dauphin et al. 2017). Residual connections (He et al. 2016) are added from input to the output of each convolution layer.
[Multi-Step Attention] Each decoder layer comprises a convolution layer followed by a multi-step attention layer. This multi-step attention is used to find the attention scores from a particular decoder state to the source tokens. Attention between decoder state did_{i} (after it​hi^{th} layer) of the last token in generated sequence so far and state zjz_{j} of the jt​hj^{th} source element (after last encoder layer) is computed as: aji=e​x​p​(di⋅zj)/∑t=1me​x​p​(di⋅zt)a_{j}^{i}={exp(d_{i}\cdot z_{j})}/{\sum\nolimits_{t=1}^{m}exp(d_{i}\cdot z_{t})} where, mm is the number of source elements. The context vector, cic_{i}, is now computed as, ci=[∑j=1maji​(zj+ej)]+dic_{i}=[\sum_{j=1}^{m}a_{j}^{i}(z_{j}+e_{j})]+d_{i} where, eje_{j} is the input embedding for the source element jj.
[Output Layer] Finally, output at a particular time step is calculated over all the ZZ possible tokens, P⁡(zt+1|z1,…,zt,X)=s​o​f​t​m​a​x​(W​dL+b)P(z_{t+1}|z_{1},\dots,z_{t},X)=softmax(Wd_{L}+b) where P(zt+1|⋅)∈ℝZP(z_{t+1}|\cdot)\in\mathbb{R}^{Z}, and WW, bb are trainable parameters. dLd_{L} is the decoder state of last target element at the last layer LL. XX is the input sequence.
[Training Loss:] The model is trained using label smoothed cross-entropy loss given by following expression (for single training example) L(θ)=−(1/N)⋅∑n=1N∑z=1Zq(yn=z|yn−1)⋅logPθ(yn=z|yn−1)L(\theta)=-({1}/{N})\cdot\sum\nolimits_{n=1}^{N}\sum\nolimits_{z=1}^{Z}q(y_{n}=z|y_{n-1})\cdot\log P_{\theta}(y_{n}=z|y_{n-1}) where, NN is the number of words in output sequence and yny_{n} is the first nn tokens of output sequence. Pθ​(yn=z|yn−1)P_{\theta}(y_{n}=z|y_{n-1}) is model’s probability to output token zz given yn−1y_{n-1} sequence generated so far. The quantity q⁡(yn=z|yn−1)q(y_{n}=z|y_{n-1}) is equal to γ\gamma if f⁡(yn)=zf(y_{n})=z and (1−γ)/(Z−1){(1-\gamma)}/{(Z-1)} o/w, where γ∈[0,1]\gamma\in[0,1], γ>1/Z\gamma>{1}/{Z}.

Stage-II: Neural Graph Search Module

While working with LC-QuAD-1 and QALD-9 datasets, our error analysis on output of Stage-I revealed that entity linking performance is reasonably good but the same is not true for relation linking. Existing literature  (Wu et al. 2020; Li et al. 2020) also show enough evidences of achieving high performance on the entity linking task, whereas relation linking turns out to be harder due to complexity of natural language. Because of this, we have most of the entities within a SPARQL silhouette generated by Stage-I as correct but the relations are incorrect. Graph search module in Stage-II takes a SPARQL silhouette as input and produces an improved version of the same by replacing incorrect relations(See Figure 10 in appendix for an example).11 1 It is easy to extend this idea and perform an iterative graph searching when entity linker performance is also low. This is a BERT-based module and its architecture is shown in Figure 5. This module works as follows.

  1. 1.

    One-by-one, we consider each triple ⟨es,r,eo⟩\langle e_{s},r,e_{o}\rangle in the SPARQL silhouette and try correcting its relation rr through this module. Note, in triple ⟨es,r,eo⟩\langle e_{s},r,e_{o}\rangle, at least one of the entity must be an existential variable unless it is an rdf:type relation, which we handle separately. We consider this triple for the correction only if the other entity is grounded to some KB entity and that grounded entity could be in subject (or object) position.

  2. 2.

    For each such triple identified in the previous step, we prepare input in the following format: [CLS] QQ [SEP] [SUB (or OBJ)] [SEP] ese_{s} (or eoe_{o}). Here, QQ is token sequence of input question text and [SUB (or OBJ)] is special token depending on whether the grounded entity is in subject (or object) position (refer Figure 5a). We also pass grounded entity (ese_{s} or eoe_{o}) as the last element of this input. [CLS] and [SEP] are special tokens from BERT vocabulary.

  3. 3.

    We feed above input sequence of tokens into the BERT layer of graph search module. The output is passed through a linear layer followed by a softmax layer. This softmax layer induces a probability score prp_{r} for each relation r∈ℛr\in\mathcal{R} in the given KG. While training, we use the following loss function (given for single example): ℓ=(1−α)∗(ℓc)+(α)∗(ℓg​s)\ell=(1-\alpha)*(\ell_{c})+(\alpha)*(\ell_{gs}). Here, ℓc\ell_{c} denotes standard cross entropy loss between predicted probabilities {pr}r∈ℛ\{p_{r}\}_{r\in\mathcal{R}} and the gold relation. The graph search loss term ℓg​s\ell_{gs} forces the predicted probabilities to be low for all those relations which are invalid relations (in the given KG) for corresponding input entity ese_{s} (or eoe_{o}) in the input position (subject or object). For this, we assume a uniform probability distribution over all such valid relations and compute its cross entropy loss with {pr}r∈ℛ\{p_{r}\}_{r\in\mathcal{R}}. α\alpha is a hyperparameter.

  4. 4.

    During inference, at softmax layer, we restrict the outputs only to those relations r∈ℛr\in\mathcal{R} which are valid relation for the input entity as being subject or object. For example, if input grounded entity is ese_{s} then we restrict prediction to only those relations rr for which ⟨es,r,?​x⟩\langle e_{s},r,?x\rangle is a valid triple for some grounding of ?​x?x. In DBpedia same relation can exist in the form of ‘dbo’ and ‘dbp’ for a specific entity. In such cases, we always pick the ‘dbo’ version. Prediction is made based out of 6162361623 relations available in DBpedia.

  5. 5.

    If a relation rr in a given triple is rdf:type then we handle them little differently. Note, in DBpedia, a triple containing rdf:type relation looks like this ⟨?x,rdf:type,dbo:type⟩\langle?x,\textit{rdf:type},\textit{dbo:type}\rangle where, ?​x?x is a variable and dbo:type is the DBpedia ontology class of the entity ?​x?x. For such triples, we maintain a separate version of the neural graph module (refer Figure 5b). Input to this module is [CLS] Q. We need to predict the corresponding ontology class dbo:type. DBpedia ontology contains 761761 classes and hence, in this model, prediction is one of these 761761 classes. This module is trained with standard cross-entropy loss. An example of the rdf:type classification would be to predict dbo:Country for the question ‘Name the country with currency as Aureus?’.

Experiments

Datasets:

We work with two different KGQA datasets based on DBpedia: LC-QuAD-1 (Trivedi et al. 2017) and QALD-9 (Ngomo 2018). LC-QuAD-1 contains 50005000 examples and is based on the 04-2016 version of the DBpedia. We split this dataset into 70%70\% training, 10%10\% validation, and 20%20\% test sets (same as the leaderboard). QALD-9 is a multilingual dataset and is based on the 10-2016 version of the DBpedia. Questions in this dataset vary in terms of reasoning nature (e.g. counting, temporal, superlative, comparative, etc.) and therefore, in terms of the SPARQL aggregation functions as well. This dataset contains 408408 training and 150150 test examples. We split the training set into 90%90\% training and 10%10\% validation sets.

Evaluation Metric:

Performance is evaluated based on the standard precision, recall, F1F_{1} score for KGQA systems. For more detail please refer to Evaluation Metric.
Baseline: We compare our approach with three baselines: WDAqua  (Diefenbach et al. 2020), QAmp  (Vakulenko et al. 2019) and gAnswer (Zou et al. 2014). WDAqua is a graph based approach where authors first develop SPARQL query based on four predefined patterns. In the second step they rerank generated candidates. QAmp used text similarity and graph structure based on an unsupervised message-passing algorithm. gAnswer is graph data driven approach and generate query graph to represent user intention.

Experimental Setup:

1) Stage-I: We use Falcon (Sakor, Singh, and Vidal 2019) for entity/relation linking and experiment with all 33 noise scenarios. We use fairseq22 2 https://github.com/pytorch/fairseq library for implementation of CNN based seq2seq model (Gehring et al. 2017) comprising of 1515 layers33 3 We will release our code after the review period.. and used Nesterov Accelerated Gradient (NAG) optimizer. We experimented with different values of hyperparameters and report results for the values yielding the best performance on the validation set. Details about tuning ranges and optimal values of all these hyperparameters are given in Table 6 and Figure 9 of appendix. We used 22 Tesla v100 GPUs for training seq2seq model.
2) Stage-II: For neural graph search module, we work with a pre-trained BERT-base uncased model. It consists of 1212 transformer layers, 1212 self-attention heads, and 768768 hidden dimension. We used 11 Tesla v100 GPU for training.

Results

Table 3 compares the performance of our model with baseline models for the LC-QuAD-1 dataset. The first two rows are top entries in the LC-QuAD-1 leaderboard 44 4 http://lc-quad.sda.tech/lcquad1.0.html. The next set of rows show result of our approach. Our results of stage-II are under realistic scenario or full noise setting for entity/relation linking.

Model Type Model Name AM Prec. Recall F1F_{1}
Baseline WDAqua - 22.0022.00 38.0038.00 28.0028.00
QAmp - 25.0025.00 50.00{\bf 50.00} 33.3333.33
Stage-I (Ours) No Noise 82.8882.88 83.1183.11 83.0483.04 83.0883.08
Part Noise 41.3441.34 42.4042.40 42.2642.26 42.3342.33
Full Noise 24.9224.92 25.54{\bf 25.54} 25.6425.64 25.5925.59
Stage-II (Ours) w/o type 30.6330.63 32.17{\bf 32.17} 32.2032.20 32.1832.18
w/ type 34.8334.83 37.03{\bf 37.03} 37.0637.06 37.05{\bf 37.05}
Table 3: Test set performance on LC-QuAD-1 dataset.

Table 4 captures the performance of our approach on QALD-9 dataset. The first two rows in Table 4 correspond to a baseline model and a top entry in the QALD-9 challenge  (Ngomo 2018). The next set of rows show performance of our model.

Model Type Model Name AM Mac. Prec. Mac. Rec. Mac. F1F_{1} Mac. F1F_{1} QALD
Baseline WDAqua - 26.126.1 26.726.7 25.025.0 28.928.9
gAnswer - 29.329.3 32.7{\bf 32.7} 29.829.8 43.0{\bf 43.0}
Stage-I (Ours) No Noise 29.929.9 80.480.4 42.142.1 40.940.9 55.355.3
Part Noise 13.113.1 63.963.9 28.728.7 22.422.4 39.639.6
Full Noise 11.111.1 82.6{\bf 82.6} 23.023.0 20.620.6 36.036.0
Stage-II (Ours) w/o type 15.315.3 59.4{\bf 59.4} 26.126.1 23.323.3 36.236.2
w/ type 15.315.3 59.4{\bf 59.4} 26.126.1 23.323.3 36.236.2
Table 4: Test set performance on QALD-9 dataset. Here Mac. means Macro and Rec. means Recall.

Insights: From Tables 3 and 4, one can observe that performance of Stage-I under No Noise linking becomes an upper bound on the performance of seq2seq model. This means seq2seq model can achieve upto 83.08%83.08\% F1F_{1} for LC-QuAD-1 and 55.3%55.3\% Macro F1F_{1} QALD for QALD-9 dataset if the entity/relation linker were to be 100%100\% correct. The gap between the performance of No Noise linking (upper bound) and Full Noise linking (lower bound) illustrates how the performance of entity/relation linker impacts the overall performance of KGQA. Further, the performance of Stage-II demonstrates how one can improve the lower bound numbers by adopting our proposed graph search module. For LC-QuAD-1, we gain 11.46%11.46\% in F1F_{1} in Stage-II whereas, for QALD-9 this gain is only 0.2%0.2\% in Macro F1F_{1} QALD. For QALD-9 dataset, the numbers in last two rows are same because we have only two questions with rdf:type and their classes belong to YAGO ontology so our model does not predict them. One may also observe that the overall performance after Stage-II improves the respective baseline in case of LC-QuAD-1 dataset but QALD-9 dataset it struggles.
Error Analysis: Reason for QALD-9 having low upper bound is its training set size being too small (367367). Further analysis reveals that QALD-9 dataset has large variety of SPARQL keywords from a small train set. Figure 6 captures the distribution of SPARQL keywords in QALD-9 dataset (excluding SELECT and DISTINCT keywords as they appear in almost all the questions). From this figure, its clear that number of questions varies from 33 to 3737 for each category of SPARQL keywords which is too less for any neural model to learn from. We also trained our model with combining LC-QuAD-1 and QALD-9 dataset in both the stages. But it did not improve the performance of QALD-9 dataset because the nature of the SPARQL is very different in both the datasets.

Figure 6: Frequency of SPARQL keywords in QALD-9.

Because of these reasons, unlike LC-QuAD-1, the generated SPARQL silhouette in QALD-9 dataset has errors other than incorrect entity/relation. Therefore, Stage-II offers much smaller gain for QALD-9 relative to LC-QuAD-1. Lastly, Table 5 which demonstrates the performance of Falcon linker on test set for both the datasets rules out the possibility of systematic data bias in terms of entity/relation linking. Though entity linking performance is reasonable for both the datasets, relation linking is consistently substandard for both the datasets. The poor performance of Falcon on relation linking also justifies a substantial gap between upper and lower bounds for both datasets.

Dataset E/R Precision (%) Recall (%)
LC-QuAD-1 E 79.1979.19 85.6085.60
R 43.7443.74 44.9944.99
QALD-9 E 78.0078.00 98.5598.55
R 41.0541.05 37.1737.17
Table 5: Falcon performance on entity (E) and relation (R) linking on test sets.

Anecdotal Examples: Table 7 of appendix shows examples from LC-QuAD-1 test set where our neural graph search module struggles to disambiguate between two very similar looking relations that exist in DBpedia for an entity. Table 8 captures examples from QALD-9 test set where gold SPARQL have an intrinsic structure because the way in which corresponding facts are being captured within DBpedia. This makes it difficult for any KB agnostic techniques (such as seq2seq) to output such structures. Finally, Table 9 shows examples from QALD-9 test set where gold SPARQL comprises infrequent SPARQL keywords making it hard for seq2seq model to learn about them.

Conclusions

We propose a simple sequential two-stage purely neural approach to solve the KGQA task. We demonstrate that, if entity/relation linking tasks are done perfectly, then Stage-I, vanilla seq2seq neural module can produce impressive performance on KGQA task. However, in noisy realistic scenarios, it performs differently. We have proposed a novel Stage-II, a neural graph search module to overcome noise introduced by entity/relation modules. Our approach improves state-of-art performance for LC-QuAD-1 dataset. Though, for QALD-9 dataset due to the small training size and intrinsic nature of facts in DBpedia, our model struggles to improve state-of-art, we believe, this research demonstrates great potential of pure neural approaches to solve the KGQA task and opens up a new research direction.

References

  • Abujabal et al. (2017) Abujabal, A.; Yahya, M.; Riedewald, M.; and Weikum, G. 2017. Automated template generation for question answering over knowledge graphs. In Proc. of WWW, 1191–1200.
  • Bahdanau, Cho, and Bengio (2015) Bahdanau, D.; Cho, K.; and Bengio, Y. 2015. Neural Machine Translation by Jointly Learning to Align and Translate. In Proc. of ICLR.
  • Bao et al. (2016) Bao, J.; Duan, N.; Yan, Z.; Zhou, M.; and Zhao, T. 2016. Constraint-based question answering with knowledge graph. In Proc. of COLING, 2503–2514.
  • Bast and Haussmann (2015) Bast, H.; and Haussmann, E. 2015. More accurate question answering on freebase. In Proc. of CIKM, 1431–1440.
  • Berant et al. (2013) Berant, J.; Chou, A.; Frostig, R.; and Liang, P. 2013. Semantic parsing on freebase from question-answer pairs. In Proc. of EMNLP, 1533–1544.
  • Bojanowski et al. (2017) Bojanowski, P.; Grave, E.; Joulin, A.; and Mikolov, T. 2017. Enriching word vectors with subword information. Transactions of the Association for Computational Linguistics, 5: 135–146.
  • Bollacker et al. (2008) Bollacker, K.; Evans, C.; Paritosh, P.; Sturge, T.; and Taylor, J. 2008. Freebase: A collaboratively created graph database for structuring human knowledge. In Proc. of ACM SIGMOD, 1247–1250.
  • Bordes et al. (2015) Bordes, A.; Usunier, N.; Chopra, S.; and Weston, J. 2015. Large-scale simple question answering with memory networks. arXiv preprint arXiv:1506.02075.
  • Cai et al. (2017) Cai, R.; Xu, B.; Yang, X.; Zhang, Z.; Li, Z.; and Liang, Z. 2017. An encoder-decoder framework translating natural language to database queries. arXiv preprint arXiv:1711.06061.
  • Cheng and Lapata (2018) Cheng, J.; and Lapata, M. 2018. Weakly-Supervised Neural Semantic Parsing with a Generative Ranker. In Proc. of CoNLL, 356–367.
  • Choi et al. (2021) Choi, D.; Shin, M. C.; Kim, E.; and Shin, D. R. 2021. Ryansql: Recursively applying sketch-based slot fillings for complex text-to-sql in cross-domain databases. Computational Linguistics, 47(2): 309–332.
  • Dai, Li, and Xu (2016) Dai, Z.; Li, L.; and Xu, W. 2016. CFO: Conditional focused neural question answering with large-scale knowledge bases. In Proc. of ACL.
  • Dauphin et al. (2017) Dauphin, Y. N.; Fan, A.; Auli, M.; and Grangier, D. 2017. Language modeling with gated convolutional networks. In Proc. of ICML, 933–941.
  • Diefenbach et al. (2020) Diefenbach, D.; Both, A.; Singh, K. D.; and Maret, P. 2020. Towards a question answering system over the Semantic Web. Semantic Web, 421–439.
  • Diefenbach et al. (2018) Diefenbach, D.; Lopez, V.; Singh, K.; and Maret, P. 2018. Core techniques of question answering systems over knowledge bases: A survey. Knowledge and Information systems, 55: 529–569.
  • Dong et al. (2015) Dong, L.; Wei, F.; Zhou, M.; and Xu, K. 2015. Question answering over freebase with multi-column convolutional neural networks. In Proceedings of the 53rd Annual Meeting of the Association for Computational Linguistics and the 7th International Joint Conference on Natural Language Processing (Volume 1: Long Papers), 260–269.
  • Dubey et al. (2019) Dubey, M.; Banerjee, D.; Abdelkawi, A.; and Lehmann, J. 2019. Lc-quad 2.0: A large dataset for complex question answering over wikidata and dbpedia. In Proc. of ISWC, 69–78.
  • Gehring et al. (2017) Gehring, J.; Auli, M.; Grangier, D.; Yarats, D.; and Dauphin, Y. N. 2017. Convolutional sequence to sequence learning. In Proc. of ICML.
  • Hao et al. (2017) Hao, Y.; Zhang, Y.; Liu, K.; He, S.; Liu, Z.; Wu, H.; and Zhao, J. 2017. An end-to-end model for question answering over knowledge base with cross-attention combining global knowledge. In Proc. of ACL, 221–231.
  • He et al. (2016) He, K.; Zhang, X.; Ren, S.; and Sun, J. 2016. Deep residual learning for image recognition. In Proc. of CVPR, 770–778.
  • He and Golub (2016) He, X.; and Golub, D. 2016. Character-level question answering with attention. In Proc. of EMNLP, 1598–1607.
  • Hosu et al. (2018) Hosu, I. A.; Iacob, R. C. A.; Brad, F.; Ruseti, S.; and Rebedea, T. 2018. Natural language interface for databases using a Dual-Encoder model. In Proceedings of the 27th International Conference on Computational Linguistics, 514–524.
  • Joshi et al. (2017) Joshi, M.; Choi, E.; Weld, D. S.; and Zettlemoyer, L. 2017. TriviaQA: A Large Scale Distantly Supervised Challenge Dataset for Reading Comprehension. In Proc. of ACL, 1601–1611.
  • Kapanipathi et al. (2020) Kapanipathi, P.; Abdelaziz, I.; Ravishankar, S.; Roukos, S.; Gray, A.; Astudillo, R.; Chang, M.; Cornelio, C.; Dana, S.; Fokoue, A.; et al. 2020. Question Answering over Knowledge Bases by Leveraging Semantic Parsing and Neuro-Symbolic Reasoning. arXiv preprint arXiv:2012.01707.
  • Lehmann et al. (2015) Lehmann, J.; Isele, R.; Jakob, M.; Jentzsch, A.; Kontokostas, D.; Mendes, P. N.; Hellmann, S.; Morsey, M.; Van Kleef, P.; Auer, S.; et al. 2015. DBpedia – A large-scale, multilingual knowledge base extracted from Wikipedia. Semantic Web, 6: 167–195.
  • Li et al. (2020) Li, B. Z.; Min, S.; Iyer, S.; Mehdad, Y.; and tau Yih, W. 2020. Efficient One-Pass End-to-End Entity Linking for Questions. In Proc. of EMNLP.
  • Li et al. (2016) Li, P.; Li, W.; He, Z.; Wang, X.; Cao, Y.; Zhou, J.; and Xu, W. 2016. Dataset and neural recurrent sequence labeling model for open-domain factoid question answering. arXiv:1607.06275.
  • Liang et al. (2017) Liang, C.; Berant, J.; Le, Q.; Forbus, K.; and Lao, N. 2017. Neural Symbolic Machines: Learning Semantic Parsers on Freebase with Weak Supervision. In Proc. of ACL, 23–33.
  • Liang (2013) Liang, P. 2013. Lambda dependency-based compositional semantics. arXiv preprint arXiv:1309.4408.
  • Liang et al. (2021) Liang, S.; Stockinger, K.; de Farias, T. M.; Anisimova, M.; and Gil, M. 2021. Querying knowledge graphs in natural language. Journal of Big Data, 8(1): 1–23.
  • Lukovnikov, Fischer, and Lehmann (2019) Lukovnikov, D.; Fischer, A.; and Lehmann, J. 2019. Pretrained transformers for simple question answering over knowledge graphs. In Proc. of ISWC.
  • Lukovnikov et al. (2017) Lukovnikov, D.; Fischer, A.; Lehmann, J.; and Auer, S. 2017. Neural network-based question answering over knowledge graphs on word and character level. In Proc. of WWW, 1211–1220.
  • Maheshwari et al. (2019) Maheshwari, G.; Trivedi, P.; Lukovnikov, D.; Chakraborty, N.; Fischer, A.; and Lehmann, J. 2019. Learning to rank query graphs for complex question answering over knowledge graphs. In Proc. of ISWC, 487–504.
  • Mitchell et al. (2015) Mitchell, T.; Cohen, W.; Hruschka, E.; Talukdar, P.; Betteridge, J.; Carlson, A.; Dalvi, B.; Gardner, M.; Kisiel, B.; Krishnamurthy, J.; Lao, N.; Mazaitis, K.; Mohamed, T.; Nakashole, N.; Platanios, E.; Ritter, A.; Samadi, M.; Settles, B.; Wang, R.; Wijaya, D.; Gupta, A.; Chen, X.; Saparov, A.; Greaves, M.; and Welling, J. 2015. Never-Ending Learning. In Proc. of AAAI.
  • Ngomo (2018) Ngomo, N. 2018. 9th challenge on question answering over linked data (QALD-9). Language, 7(1).
  • Nguyen et al. (2016) Nguyen, T.; Rosenberg, M.; Song, X.; Gao, J.; Tiwary, S.; Majumder, R.; and Deng, L. 2016. MS MARCO: A human generated machine reading comprehension dataset. In CoCo@ NIPS.
  • Pellissier Tanon, Weikum, and Suchanek (2020) Pellissier Tanon, T.; Weikum, G.; and Suchanek, F. 2020. YAGO 4: A Reason-able Knowledge Base. In Proc. of ESWC, 583–596.
  • Petrochuk and Zettlemoyer (2018) Petrochuk, M.; and Zettlemoyer, L. 2018. SimpleQuestions Nearly Solved: A New Upperbound and Baseline Approach. In Proc. of EMNLP, 554–558.
  • Rajpurkar et al. (2016) Rajpurkar, P.; Zhang, J.; Lopyrev, K.; and Liang, P. 2016. SQuAD: 100,000+ questions for machine comprehension of text. In Proc. of EMNLP, 2383–2392.
  • Reddy, Lapata, and Steedman (2014) Reddy, S.; Lapata, M.; and Steedman, M. 2014. Large-scale semantic parsing without question-answer pairs. Transactions of the Association for Computational Linguistics, 2: 377–392.
  • Sakor, Singh, and Vidal (2019) Sakor, A.; Singh, K.; and Vidal, M. E. 2019. FalCon: An entity and relation linking framework over DBpedia. In Proc. of CEUR Workshop, volume 2456, 265–268.
  • Singh et al. (2018) Singh, K.; Both, A.; Sethupat, A.; and Shekarpour, S. 2018. Frankenstein: A platform enabling reuse of question answering components. In Proc. of ESWC, 624–638. Springer.
  • Steiner et al. (2012) Steiner, T.; Verborgh, R.; Troncy, R.; Gabarro, J.; and Van de Walle, R. 2012. Adding realtime coverage to the Google knowledge graph. In Proc. of ISWC.
  • Su et al. (2016) Su, Y.; Sun, H.; Sadler, B.; Srivatsa, M.; Gür, I.; Yan, Z.; and Yan, X. 2016. On generating characteristic-rich question sets for qa evaluation. In Proc. of EMNLP, 562–572.
  • Trivedi et al. (2017) Trivedi, P.; Maheshwari, G.; Dubey, M.; and Lehmann, J. 2017. LC-QuAD: A corpus for complex question answering over knowledge graphs. In Proc. of ISWC, 210–218.
  • Unger et al. (2012) Unger, C.; Bühmann, L.; Lehmann, J.; Ngonga Ngomo, A.-C.; Gerber, D.; and Cimiano, P. 2012. Template-based question answering over RDF data. In Proc. of WWW, 639–648.
  • Usbeck et al. (2017) Usbeck, R.; Ngomo, A.-C. N.; Haarmann, B.; Krithara, A.; Röder, M.; and Napolitano, G. 2017. 7th open challenge on question answering over linked data (QALD-7). In Semantic Web Evaluation Challenge, 59–69.
  • Vakulenko et al. (2019) Vakulenko, S.; Fernandez Garcia, J. D.; Polleres, A.; de Rijke, M.; and Cochez, M. 2019. Message passing for complex question answering over knowledge graphs. In Proc. of CIKM, 1431–1440.
  • Vaswani et al. (2017) Vaswani, A.; Shazeer, N.; Parmar, N.; Uszkoreit, J.; Jones, L.; Gomez, A. N.; Kaiser, Ł.; and Polosukhin, I. 2017. Attention is all you need. In Proc. of NIPS, 5998–6008.
  • Wang et al. (2020) Wang, B.; Shin, R.; Liu, X.; Polozov, O.; and Richardson, M. 2020. Rat-sql: Relation-aware schema encoding and linking for text-to-sql parsers.
  • Wu et al. (2020) Wu, L.; Petroni, F.; Josifoski, M.; Riedel, S.; and Zettlemoyer, L. 2020. Scalable Zero-shot Entity Linking with Dense Entity Retrieval. In Proc. of EMNLP.
  • Yao and Van Durme (2014) Yao, X.; and Van Durme, B. 2014. Information extraction over structured data: Question answering with freebase. In Proceedings of the 52nd Annual Meeting of the Association for Computational Linguistics (Volume 1: Long Papers), 956–966.
  • Yin and Neubig (2017) Yin, P.; and Neubig, G. 2017. A syntactic neural model for general-purpose code generation. In Proc. of ACL, 440–450.
  • Yin et al. (2016) Yin, W.; Yu, M.; Xiang, B.; Zhou, B.; and Schütze, H. 2016. Simple Question Answering by Attentive Convolutional Neural Network. In Proceedings of COLING 2016, the 26th International Conference on Computational Linguistics: Technical Papers, 1746–1756. The COLING 2016 Organizing Committee.
  • Yin, Gromann, and Rudolph (2021) Yin, X.; Gromann, D.; and Rudolph, S. 2021. Neural machine translating from natural language to SPARQL. Future Generation Computer Systems, 117: 510–519.
  • Yu et al. (2017) Yu, M.; Yin, W.; Hasan, K. S.; dos Santos, C.; Xiang, B.; and Zhou, B. 2017. Improved Neural Relation Detection for Knowledge Base Question Answering. In Proc. of ACL.
  • Yu et al. (2018) Yu, T.; Li, Z.; Zhang, Z.; Zhang, R.; and Radev, D. R. 2018. TypeSQL: Knowledge-Based Type-Aware Neural Text-to-SQL Generation. In NAACL.
  • Zettlemoyer and Collins (2005) Zettlemoyer, L. S.; and Collins, M. 2005. Learning to map sentences to logical form: structured classification with probabilistic categorial grammars. In Proc. of UAI.
  • Zou et al. (2014) Zou, L.; Huang, R.; Wang, H.; Yu, J. X.; He, W.; and Zhao, D. 2014. Natural language question answering over RDF: a graph data driven approach. In Proceedings of the 2014 ACM SIGMOD international conference on Management of data, 313–324.

Appendix

Noise Simulator

Figure 7: An illustrative example for Scenario ‘A’: Noise-Free Linking. To align the surface forms of the entities/relations mentions in the given question text, we used word embedding as it offers higher alignment F1F_{1}. We used Falcon as a linker.
Figure 8: An illustrative example for Scenario ‘B’: Partly Noisy Linking. To align the surface forms of the entities/relations mentions in the given question text, we used exact match as well as string overlap based Jaccard similarity with a threshold of 0.70.7. We used Falcon as a linker.
Hyperparameter Tuning Range Best Value
η\eta for Stage-I [0.10.1, 0.20.2, 0.250.25, 0.500.50] 0.250.25
η\eta for Stage-II [10−410^{-4}, 10−510^{-5}, 10−610^{-6}] 10−510^{-5}
bb for both stages 88 88
α\alpha for LC-QuAD-1 [0.10.1, 0.40.4, 0.60.6, 0.70.7] 0.40.4
α\alpha for QALD-9 [0.10.1, 0.40.4, 0.60.6, 0.70.7] 0.60.6
Table 6: Tuning range and the final chosen best values of various hyperparameters. η\eta means learning rate and bb means batch size.
Figure 9: Change in validation set accuracy with hyperparameter α\alpha
Figure 10: An example of input to the neural graph search module.
Question Gold Relation Predicted Relation
Where was the person born who died in Bryn Mawr Hospital? placeOfDeath deathPlace
Name the rivers who originate from Essex? mouthPlace sourceRegion
Name the artist who made Dream Dancing and is often associated with Joe Pass. associatedBand associatedMusicalArtist
What is used as money for French Southern and Antarctic Lands is also the product of the Karafarin Bank ? product products
Table 7: Anecdotal examples from LC-QuAD-1 test set where graph search module is unable to disambiguate between two closely related relations (gold and predicted) that are available for the highlighted entities in DBpedia.
Question Gold SPARQL SPARQL silhouette
Who was called Scarface? SELECT ?uri WHERE { ?uri dbo:alias ?alias FILTER contains(lcase(?alias),
”scarface”)
}
SELECT DISTINCT ?uri WHERE { dbr:Scarface dbo:alias ?uri }
Who was called Rodzilla? SELECT DISTINCT ?uri WHERE { ?uri <http://xmlns.com/foaf/0.1/nick>
“Rodzilla”@en
}
SELECT DISTINCT ?uri WHERE { dbr:Rodzilla dbo:alias ?uri }
Give me all gangsters from the prohibition era. SELECT DISTINCT ?uri WHERE { ?uri dbo:occupation dbr:Gangster ; dct:subject dbc:Prohibition-eragangsters
}
SELECT DISTINCT ?uri WHERE { ?uri a dbo:Film ; dbo:time dbr:Gangsters_of_the_Frontier }
Table 8: Anecdotal examples from QALD-9 test set where gold SPARQL have a peculiar structure just because the specific way in which the corresponding facts are present in the DBpedia.
Question Gold SPARQL SPARQL silhouette
Which countries have more than ten volcanoes? SELECT DISTINCT ?uri WHERE { ?x a dbo:volcano ; dbo:locatedInArea ?uri . ?uri a dbo:Country } GROUP BY ?uri HAVING ( COUNT(?x) >10 ) SELECT DISTINCT ?uri WHERE { ?uri a dbo:Country ; dbo:location dbr:Countries_of_the_United_Kingdom }
Give me a list of all critically endangered birds. SELECT DISTINCT ?uri ?p WHERE { ?uri rdf:type dbo:Bird { ?uri dbo:conservationStatus ”CR” } UNION { ?uri dct:subject dbc:Critically_endangered_animals } } SELECT DISTINCT ?uri WHERE { ?uri a dbo:Film ; dbo:principal dbr:Endangered_Species_(H.A.W.K._album }
Which daughters of British earls died at the same place they were born at? SELECT DISTINCT ?uri WHERE { ?uri rdf:type yago:WikicatDaughtersOfBritishEarls ; dbo:birthPlace ?x ; dbo:deathPlace ?y FILTER ( ?x = ?y ) } SELECT DISTINCT ?uri WHERE { ?uri rdf:type yago:WikicatStatesOfTheUnitedStates ; dbo:place dbr:Daughters_of_the_Dust }
Table 9: Anecdotal examples from QALD-9 test set where gold SPARQL comprises infrequent SPARQL keywords. The corresponding SPARQL Silhouette predicted by our Stage-I is also shown for these examples.

Evaluation Metric

1) Precision, Recall, and F1F_{1} for Single Question: For single question QQ, we compute precision PP, recall RR, and F1F_{1} using the set of gold answer entities SgS_{g} and predicted answer entities SpS_{p}. While computing these metrics, we handle boundary cases as follows. If Sg=Sp=∅S_{g}=S_{p}=\emptyset then we take P=R=F1=1P=R=F_{1}=1. If only Sg=∅S_{g}=\emptyset then we take R=F1=0R=F_{1}=0.
2) Macro Precision, Macro Recall, Macro F1F_{1}, and Macro F1F_{1} QALD: These metrics are defined for the whole dataset. For this, we first compute PP, RR, and F1F_{1} at individual question level and average of these numbers across entire dataset gives us the macro version of these metrics. For F1F_{1}, if use the boundary condition of having P=1P=1 when Sp=∅,Sg≠∅S_{p}=\emptyset,S_{g}\neq\emptyset then such a Macro F1F_{1} is called as Macro F1F_{1} QALD as per Ngomo 2018. But if we instead use P=0P=0 then it is called Macro F1F_{1}.
3) Precision, Recall, and F1F_{1} for the whole set: For whole set, PP and RR are same as macro version of these metrics. F1F_{1}, however, is computed by taking Harmonic mean of these PP and RR. The reported metrics for the LC-QuAD-1 dataset were computed in this manner.
4) Answer Match (AM): For a question QQ, when executing the predicted SPARQL, if we have Sp=SgS_{p}=S_{g} then we say AM=1 otherwise AM=0.

Anecdotal Examples

Table 7 shows examples from LC-QuAD-1 test set where our neural graph search module is unable to disambiguate between two very similar looking relations that exist in DBpedia for an entity.

Table 8 captures examples from QALD-9 test set where gold SPARQL have a peculiar structure just because the way in which corresponding facts are being captured within in the DBpedia and that makes it almost impossible for any KB agnostic techniques (such as seq2seq) to output such structures. The first two rows of Table 7 shows examples where gold SPARQL queries of two very similar questions is quite different. Even though Falcon picks correct entities, our SPARQL silhouette struggle to yield two differently structured SPARQL queries for two very similar looking natural language questions. Third row of the table contains some entities/relations containing dct, dbc, etc. Falcon linker does not tag these kinds of entity/relation, so we miss out correctly predicting the sketch in Stage-I and so in Stage-II as well.

Table 9 shows various examples from QALD-9 test set where we miss predicting the correct sketch of SPARQL because of very few number of such examples present in the training set. These are examples where SPARQL contains infrequent keywords such as GROUP BY, UNION, FILTER etc.