OAuth 2.0 authorization using blockchain-based tokens
Abstract
OAuth 2.0 is the industry-standard protocol for authorization. It facilitates secure service provisioning, as well as secure interoperability among diverse stakeholders. All OAuth 2.0 protocol flows result in the creation of an access token, which is then used by a user to request access to a protected resource. Nevertheless, the definition of access tokens is transparent to the OAuth 2.0 protocol, which does not specify any particular token format, how tokens are generated, or how they are used. Instead, the OAuth 2.0 specification leaves all these as design choices for integrators. In this paper, we propose a new type of OAuth 2.0 token backed by a distributed ledger. Our construction is secure, and it supports proof-of-possession, auditing, and accountability. Furthermore, we provide added-value token management services, including revocation, delegation, and fair exchange by leveraging smart contracts. We realized a proof-of-concept implementation of our solution using Ethereum smart contracts and the ERC-721 token specification.
I Introduction
OAuth 2.0 [1] has received widespread adoption and it is considered the industry-standard protocol for authorization. OAuth 2.0 enables delegation and interoperability, it enhances end-user security, and it facilitates access control management. Due to its intriguing properties, it is being used in environments with higher security requirements than initially considered, such as IoT systems, Open Banking, eHealth, eGovernment, and Electronic Signatures [2].
In a nutshell, OAuth 2.0 constitutes the protocol through which an client obtains an access token from an authorization server, to access a protected resource, stored in a resource server. However, OAuth 2.0 specification does not define how an access token is generated, validated, and destroyed; instead it leaves the management of OAuth 2.0 tokens’ lifecycle as an open design choice.
In this paper, we propose a new type of token, which is protected using proof-of-possession keys and at the same time it supports auditing and accountability, fast revocation, and added-value services. In order to achieve our goal, we build on the emerging distributed ledger technology (DLT). Our solution considers an append-only distributed ledger (public or private), where users, identified by a public key, can transact uniquely identified tokens. Our implementation is based on the Ethereum blockchain and the ERC-721 token specification (but other similar technologies can be considered). Our system leverage Ethereum’s support for distributed apps (referred to as smart contracts) to build blockchain-based token management services. The proposed solution has the following advantages:
- •
The entity that generates access tokens (i.e., the authorization server) can easily revoke them before they expire. Furthermore, token revocation does not involve any interaction with the client or the resource server, hence it can be implemented even if these entities are offline/unreachable. Similarly, a resource server can verify the validity of a token (i.e., it has not been revoked) even if the authorization server is offline, since token revocation is recorded on the DLT through a transaction that can occur at any time prior to the token’s usage.
- •
Clients do not have to store their tokens locally, neither do they have to store any secret associated with their access tokens. Instead, all tokens can be retrieved form the ledger. Hence, tokens are portable and can be easily used by multiple client devices. Furthermore, since we are using a popular token specification, a wide range of “wallets” and libraries can be supported by our system.
- •
Token integrity and authenticity can be verified simply by performing a lookup in the ledger, and it does not involve any signature verification or any other cryptographic operation. Therefore, our solution is less prone to implementation errors, and tokens are simpler since the do not carry any cryptographic proof. Furthermore, token ownership can be securely modified without any interaction with the authorization server.
- •
All tokens, including the revoked ones, are immutably stored in the ledger, hence auditing and accountability mechanisms are facilitated.
The feasibility of our solution is verified through a proof-of-concept implementation, inspired by an IoT gateway access use case. The remainder of this paper is organized as follows. In Section II, we introduce OAuth 2.0 and ERC-721 tokens. In Section III we present the design of our system, and in Section IV we detail the provided token management services. Finally, we present our implementation and its evaluation in Section V, and we conclude in Section VI.
II Background and related work
II-A OAuth 2.0
OAuth 2.0 systems are composed of the following entities. A resource server that hosts a protected resource owned by a resource owner, a client wishing to access that resource, and an authorization server responsible for generating access tokens. Access tokens are granted to clients authorized by the resource owner: client authorization is proven using an authorization grant. These interactions are illustrated in Fig. 1. As it can be seen in this figure, a client first requests an authorization grant from the resource owner, then it uses this grant to obtain an access token from the authorization server, and finally, it uses the access token to access the protected resource stored in the resource server. The semantics, as well as the mechanisms for generating and validating access tokens and grants are transparent to the OAuth 2.0 protocol.
Each OAuth 2.0 deployment may choose the type of token it will use. The most commonly used type of token is the bearer token [3], which can be used by any user who possesses it (i.e., the “bearer”). For additional security, a token can be associated with a secret key, so that only users who can prove that they possess this key can use the token. Since the latter type of tokens provides more security (at the cost of the communication overhead required to verify ownership) it is considered by our solution. In particular, our constructions are based on JSON Web Tokens (JWTs) [4] enhanced with blockchain-based proof-of-possession mechanisms.
A JWT is a compact, URL-safe means of representing “claims.” It consists of zero or more name/value pairs, and it is transmitted encoded in base64url [5]. RFC 7519 defines some “standard” claim names and their semantics. Table I contains the names, and the corresponding semantics, of the JWT claims used by our solution.
| Name | Semantics |
|---|---|
| iss | The issuer of the token |
| sub | The subject of the token, i.e., the entity that will use the token to gain access to a resource |
| aud | The audience of the token, i.e., the the recipients that the JWT is intended for |
| exp | The expiration time on or after which the JWT must not be accepted for processing |
| jti | A unique token identifier |
II-B Ethereum and ERC-721
Ethereum [6] is a popular blockchain system that supports distributed applications, known as “smart contracts”. A smart contract is executed by all “peers” in the Ethereum network and its outcome is agreed upon consensus. Users interact with a smart contract by issuing “transactions,” which are signed by a user-specific key. A hash of this key is used as the user “address” and it is used for associating users with information stored in the blockchain. All transactions are immutably recorded in the blockchain, for this reason blockchain-based solutions are ideal for implementing auditing and accountability mechanisms. Furthermore, a smart contract can create an “event”. Events are also recorded in the blockchain and end-user applications can be configured to “listen” for specific contract events.
Ethereum community is developing ‘‘Ethereum Request for Comments’’ (ERC), which the equivalent of RFC but for smart contract. ERC-72111 1 https://eips.ethereum.org/EIPS/eip-721, is an open standard that describes how to build ‘‘non-fungible or unique tokens on the Ethereum blockchain.’’ This standard is very similar, in many ways, to ERC-2022 2 https://eips.ethereum.org/EIPS/eip-20, which probably the most popular Ethereum standard and it is used for creating custom Ethereum tokens. However, in contrast to ERC-20 tokens, ERC-721 tokens are ‘‘unique’’ and non-interchangeable with other tokens (non-fungibility). Many Ethereum wallets, such as Metamask33 3 https://metamask.io/, can handle these tokens. All ERC-721-based tokens are identified by a unique identifier (we will refer to this identifier as ), and they can be owned only by a single user.
This standard, like every other token standard in Ethereum, defines some functions that a smart contract should implement in order to be able to create and handle ERC-721 tokens. Furthermore, the ERC-721 metadata extension, defines some additional functions that can be used for associating an ERC-721 token with metadata. Table II describes the functions defined in ERC-721 and in ERC-721 metadata extension, used by our system.
| Name | Purpose |
|---|---|
| ownerOf() | It accepts as input a and returns the address of the token owner |
| transferFrom(from, to, ) | It transfers a from one Ethereum address to another |
| approve(address,) | It approves an Ethereum address to manage a on owner’s behalf |
| getApproved() | It retrieves the Ethereum address that is allowed to manage |
| tokenURI() | It accepts as input a and returns a URI that point to token’s metadata |
Additionally, functions transferFrom and approve, when invoked each generates an event, named Transfer and Approval respectively. Both these events have three attributes; the attributes of the Transfer event are the address, the address, and the , while the attributes of the Approval event are the owner address, the approved address, and the .
II-C Related work
Many recent research efforts investigate Blockchain-based access control, either by defining custom blockchain systems (e.g., [7]) or by using Ethereum smart contracts for recording policies and for implementing on-chain access control decisions (e.g., [8, 9, 10, 11, 12]). Our solution does not rely on smart contracts for implementing access control decisions (which may cause privacy issues), instead it uses the ledger for storing auxiliary information used for validating OAuth 2.0 access tokens.
The work in this paper is related to our previous work published in [13, 14, 15]. However, in these papers we considered constrained devices not capable of accessing the blockchain. In this paper we relax this assumption and we consider resource servers capable of reading values from the blockchain (resource servers are not required to “write” in the blockchain); even with read-only access we can implement constructions that were not possible with our previous work, including revocation, and delegation.
III System design
Our system considers a typical OAuth 2.0 architecture (such as the one described in section II-A). Therefore, the main entities of our system are clients, authorization servers, resource servers, and resource owners. From a high-level perspective, our system operates as follows. The client requests an access token from the authorization server, using an authorization grant received by the resource owner. The authorization server validates the authorization grant of the client, generates a JWT and an ERC-721 token, transfers the ERC-721 token to the Ethereum address of the client, and transmits the JWT to the client. Then, the client requests access from the resource server, providing the JWT. The resource server retrieves the corresponding ERC-721 token which is used for verifying the validity and the ownership of the JWT: if all verifications are successful the resource server allows the client request. This process is illustrated in Figure 2.
III-A Notation and security assumptions
In our system, resources are uniquely identified by a URI, referred to as the . We assume a security mechanism with which a resource server can prove that it hosts a specific (e.g., using an X.509 certificate). Henceforth, when we say that “a client requests from a resource server” it is assumed that the client has already verified ownership. Moreover, the communication between a client and a resource server takes place over a secure communication channel.
In our system each authorization server owns an ERC-721 contract, referred to as ; we detail these smart contracts in the following section. Moreover, we assume a security mechanism with which clients and authorization servers can securely communicate; this mechanism provides confidentiality and integrity protection of the exchanged messages, as well as authorization server authentication. Furthermore, resource owners trust authorization servers to behave according to the specified procedures.
Finally, each client owns a public key , and a corresponding private key, used for transacting with the Ethereum blockchain. Again, we consider a security mechanism with which ownership can be verified.
III-B The ERC-721 contract
ERC-721 contracts in our system are implemented such that only the contract owner can create new tokens. When a token is created its and are specified: these two properties are read-only and they cannot be modified. Moreover, token owners in our system cannot transfer their tokens; the only entity that can invoke the transferFrom method is the contract owner. Moreover, when invoking the transferFrom method, the contract owner is allowed to transfer any token, no matter who the token owner is.
The ERC-recommended approach for associating a token with some metadata is through the metadata extension, which provides a method that maps a to a URI where metadata are stored (i.e., tokenURI). Nevertheless, we postulate that this approach violates both the decentralization and immutability principles of DLTs, since with this approach the metadata file is stored in a centralized location, and it can be modified without being possible to track or even detect the changes. For this reason, in our system, metadata are encoded in a JWT and the base64url representation of the JWT is stored in the contract: this is the return value of the tokenURI method. Therefore, in our system, the metadata extension is used to retrieve the metadata themselves and not a URI that points to the metadata.
III-C Setup
During setup, resource owners configure their resource servers with . Moreover, clients ‘‘register’’ with the authorization server.44 4 This registration step is also assumed by the OAuth protocol. During this registration process, which is out of the scope of this paper, the authorization server learns the Ethereum public key of the client (i.e., ). In cases where this registration process cannot take place a priori, solutions such as the OAuth 2.0 dynamic client registration protocol [16] can be considered.
Additionally, prior to any other operation, each client obtains from the resource owner an authorization grant (the format of this grant and the mechanisms for generating it are out of the scope of this paper). This grant represents a resource owner’s authorization, and is used by a client to request an access token for a specific .
III-D Access token request
A client, that owns , requests from an authorization server an access token for a protected resource , including in the request the authorization grant received during the setup. The authorization server verifies ownership and grant validity (using protocols out of the scope of this paper). Then, the authorization server creates a JWT which contains the following claims: ⬇ 1 { 2 “iss”: “”, 3 “sub”: “”, 4 “aud”: “” 5 “jti”: “” 6 “exp”: “expiration time” 7 }
As a next step, the authorization server creates an ERC-721 token. The of this new token matches the value specified by the jti claim of the JWT. Moreover, the metadata of the token is set equal to the base64url encoding of the JWT. Finally, the authorization server invokes the transferFrom method of the ERC-721 contract to transfer the created token to , and sends the generated JWT back to the client. It should be noted that the client does not have to store the JWT: at any time it can retrieve all the tokens it owns from the ERC-721 contract, and extract the corresponding JWT from a token’s metadata.
III-E Resource access request
In order for a client to access a protected resource, it sends to the resource server a request that includes the received JWT. The resource server performs the following steps:
- 1.
It examines: (i) if it “knows” the included in the iss claim of the JWT (i.e., if it has been configured with this contract address), (ii) if the included in the aud claim of the JWT matches the URI of the requested resource, and (iii) if the token is still valid (i.e., it has not expired).
- 2.
It executes the ownerOf method of , providing as input the included in the jti claim of the JWT, and examines if the returned address corresponds to included in the sub claim of the JWT.
- 3.
It executes the tokenURI method of , and examines if the returned string is the same as the received JWT.
At this point, the resource server is able to attest the integrity of the received JWT (since it is the same as the metadata of the token stored in the blockchain), as well as its validity. As a next step, the resource server verifies that the client is the real owner of . If all verifications succeed, the resource server accepts the client’s request.
Additionally, a resource server may store a valid JWT locally, create a session identifier, and send this identifier to the client: the client may use this identifier, as long as the JWT is still valid, accelerating this way subsequent requests for the same resource.
IV Token management services
IV-A Revocation
Tokens usually carry an expiration time: OAuth 2.0 and JWTs specifications do not provide any mechanism that allows an authorization server to revoke an access token prior to its expiration time. Even “OAuth 2.0 token revocation RFC [17],” specifies a mechanism that allows “clients to notify the authorization server that a […] access token is no longer needed,” i.e., a mechanism that provides a “log out” functionality rather than revocation.
In our system, tokens can be revoked by an authorization server by invoking the transferFrom method of the ERC-721 contract and transferring a token back to the authorization server.55 5 It is reminded that authorization servers are the contract owners, and contract owners in our system are allowed to transfer any token, no matter who the token owner is. We consider two cases: (i) the corresponding JWT has not been used by the client by the time of the revocation, and (ii) the corresponding JWT has been used, it has been stored locally by the resource server, and it has been associated with a session identifier. In the former case, when a client tries to use the JWT the verification process will fail, since the output of the ownerOf method will not match the included in the sub claim of the JWT, hence the resource server will reject the JTW. In the latter case, the resource server must “listen” for the events emitted by the transferFrom method; if an event contains a included in an already stored JWT, the resource server must delete the JWT and the associated session identifier. It should be noted that events are immutably stored in the blockchain, hence if a resource server is offline for some time, it can easily recover all missed events.
IV-B Delegation
There can be cases where a client does not wish to authenticate to the resource server using , e.g., may be stored in a secure, offline storage place, or a user may want to temporary use another device that does not have access to (for example a user may want to use different devices while travelling). For these cases, our system allows a token owner to delegate an access token to another Ethereum address. The token does not change ownership, and the latter address is not allowed to further delegate the token. We implement this functionality by using the approve method of the ERC-721 contract and the “proof-of-possession key Semantics for JWTs” defined in RFC 7800 [18]. RFC 7800 defines a “confirmation” (cnf) claim, which contains the key of the owner of a JWT. Delegation of a is implemented as follows: invokes the approve method providing as input and the Ethereum address associated with the public key of the delegee . Now can use this token by constructing a JWT and by adding in the cnf claim as illustrated in listing .
The cnf claim is not recorded in the ERC-721 token’s metadata, since metadata are read-only. For this reason, when performs a resource access request, Step 3 of token integrity verification is modified as follows. It should be noted that when a token is revoked, the delegee can not use it.
- 3.
The resource server executes the tokenURI method of , and examines if the returned string is the same as the received JWT excluding the cnf claim.
Then, JWT ownership is verified as follows: the resource server executes the getApproved method of the ERC-721 contract, providing as input , and examines if the return value equals to the Ethereum address associated with ; finally, it challenges client to verify ownership.
The delegation process does not involve the resource owner, neither the authorization server.
IV-C Fair exchange
Smart contracts are ideal for performing “fair exchange” of digital goods [19]. In our previous work, published in [15], we used smart contracts to exchange an access token for money. In a nutshell, with the solution presented in [15] the authorization server encrypts a token, the client “deposits” some money in the form of escrow, and the server receives the escrow only if it reveals the “correct” decryption key. The problem with this approach is that it does not provide any guarantee that the decrypted plaintext is a valid access token.
With the solution presented in this paper this problem is solved as follows: the authorization server creates the ERC-721 token, and stores it in the ERC-721 smart contract by “indicating” a ; the contract transfers the token to only when the latter performs an action (e.g., pay a pre-specified amount of money). The advantage of this approach is that the client can inspect the token before performing any action; of course the client cannot use the token, before performing the specified action, since up until this point, the client does not own the token.
V Implementation and Evaluation
V-A Implementation
We have developed a proof of concept implementation of the presented solution. We considered the case of an IoT gateway access, the owner of which wishes to grant access to guest users. As an IoT gateway we used Mozilla’s WebThings Gateway66 6 https://iot.mozilla.org/gateway/ that implements the WoT standard [20]. For our proof of concept, we chose not to modify the gateway itself, instead, we have developed an application that acts as a proxy, between the client, the blockchain, and the gateway (that holds the role of the resource server).
As an Ethereum wallet, we used the Metamask Firefox extension, which can handle ERC-721-based tokens. We implemented clients as JavaScript web applications using web3.js Ethereum JavaScript API.77 7 https://web3js.readthedocs.io/
The main component of our proposed system is the smart contract that implements the functions of the ERC-721 interface. The smart contract was developed using Solidity88 8 https://solidity.readthedocs.io/en/v0.5.6/, which is a Turing-complete programming language for implementing smart contracts. In addition to the functions included in Table II we implemented two functions that are not defined in the ERC-721 interface. The first one, named mint, is for creating new tokens, and the other, named burn, for “burning” tokens, i.e., for destroying them. These functions, as well as the transferFrom and approve functions, can only be invoked by the smart contract owner.
V-B Performance and Cost Evaluation
We have tested our proposed system in the Rinkeby Ethereum test network99 9 https://www.rinkeby.io/. We chose a public test network rather than a private one in order to have more reliable results.
The actions of our system that involve the invocation of the smart contract functions, create some computational overhead. Gas is Ethereum’s unit for measuring the computational and the storage resources required. Each operation of a smart contract costs a fix amount of gas. Gas cost is the number of units of gas required to perform an action, while gas price is the amount of ‘‘ether’’ (i.e., Ethereum’s specific coin) a client is willing to pay per unit of gas. The average price of a unit of gas1010 10 As measured by https://ethgasstation.info on 30 Dec. 2019 is $. Table III shows the cost of deploying the smart contract in the blockchain network, as well as the cost of operations performed by our system in terms of gas units.
| Operation | Cost measured in gas |
|---|---|
| Contract Deployment | 1585444 |
| Create a token | 254141 |
| Burn a token | 85791 |
| Transfer a token | 63858 |
| Approve | 45735 |
In addition to gas, Ethereum adds an execution time overhead related to the time the Ethereum network needs to generate a new block. On average, an operation in Ethereum is executed in 13 seconds.
Some of the aforementioned functions are declared as view functions. That is, they only read state of the blockchain without modifying it. Thus, they incur no cost, delay, or overhead. These functions are: tokenURI, getApproved, and ownerOf.
V-C Discussion
Privacy considerations. With our solution, an authorization server does not have to be aware of the resource server, i.e., they never have to communicate directly, not even in the case of a token revocation. The authorization server learns only the that a client wants to access, but this does not have to be the real URI of the resource: any pseudonym that the resource server can understand can be used instead. On the other hand, the metadata of an ERC-721 token are immutable and visible to anybody, constituting a privacy threat. In order to enhance clients’ privacy metadata can be encrypted using a key known only to the resource owner, to the client, and to the resource server.
Authorization server key breach. In order to enhance the security of our solution we specify that some functions of the ERC-721 contract can only be executed by the contract owner, i.e., the authorization server. Of course, if the private key the authorization server used for deploying the contract is compromised then, the security of our system is jeopardized and a new contract has to be deployed (which requires re-configuration of the resource servers). For this reason, a realization of our system may consider two different keys: one for invoking the security critical functions of the smart contract, and another for specifying which is the former key. The latter key can be the one used for deploying the contract and can be securely stored offline.
Approving other types of identifiers. ERC-721 specifications define that with the approve method a token owner can specify another Ethereum address that can manage its token. However, in our system a delegee never interacts with the blockchain, therefore the input to approve does not have to be an Ethereum address. Other types of delegee identifiers can be considered, such as legacy public keys, or even contemporary forms of authentication such as verifiable credentials [21].
VI Conclusions
In this paper we presented the design and implementation of an OAuth 2.0 authorization token, backed by blockchain-based smart contracts. Our solution uses Ethereum to store information that can be used for auditing purposes, as well as for token integrity verification. Ethereum smart contracts facilitate revocation, decouple authorization and resource servers, enable token delegation, and create opportunities for exchanging tokens with fungible assets. We believe that our work can be extended towards many directions, including the use of permissioned ledgers, token validation using conditions stored in the ledger, privacy-preserving token representations, and the application of similar mechanisms for managing authorization grants.
References
- [1] D. Hardt (ed.), “The OAuth 2.0 authorization framework,” IETF, RFC 6749, 2012.
- [2] T. Lodderstedt, J. Bradley, A. Labunets, and d. Fett, “OAuth 2.0 security best current practice,” IETF, draft-RFC, 2019.
- [3] M. Jones and D. Hardt, “The OAuth 2.0 authorization framework: Bearer token usage,” IETF, RFC 6750, 2012.
- [4] M. Jones, J. Bradley, and N. Sakimura, “JSON Web Token (JWT),” IETF, RFC 7519, 2015.
- [5] S. Josefsson, “The Base16, Base32, and Base64 data encodings,” IETF, RFC 4648, 2006.
- [6] G. Wood, “Ethereum: A secure decentralised generalised transaction ledger,” Ethereum Project Yellow Paper, vol. 151, 2014.
- [7] A. Dorri, S. S. Kanhere, R. Jurdak, and P. Gauravaram, “Blockchain for iot security and privacy: The case study of a smart home,” in 2017 IEEE International Conference on Pervasive Computing and Communications Workshops (PerCom Workshops), March 2017, pp. 618–623.
- [8] M. T. Hammi, B. Hammi, P. Bellot, and A. Serhrouchni, “Bubbles of trust: A decentralized blockchain-based authentication system for iot,” Computers and Security, vol. 78, pp. 126 – 142, 2018. [Online]. Available: http://www.sciencedirect.com/science/article/pii/S0167404818300890
- [9] O. Novo, “Blockchain meets iot: An architecture for scalable access management in iot,” IEEE Internet of Things Journal, vol. 5, no. 2, pp. 1184–1195, April 2018.
- [10] Y. Zhang, S. Kasahara, Y. Shen, X. Jiang, and J. Wan, “Smart contract-based access control for the internet of things,” IEEE Internet of Things Journal, pp. 1–1, 2019.
- [11] G. Ali, N. Ahmad, Y. Cao, M. Asif, H. Cruickshank, and Q. E. Ali, “Blockchain based permission delegation and access control in internet of things (baci),” Computers & Security, vol. 86, pp. 318 – 334, 2019. [Online]. Available: http://www.sciencedirect.com/science/article/pii/S0167404819301208
- [12] D. D. F. Maesa, P. Mori, and L. Ricci, “A blockchain based approach for the definition of auditable access control systems,” Computers & Security, vol. 84, pp. 93 – 119, 2019. [Online]. Available: http://www.sciencedirect.com/science/article/pii/S0167404818309398
- [13] N. Fotiou, V. A. Siris, and G. C. Polyzos, “Interacting with the Internet of Things Using Smart contracts and blockchain technologies,” in Security, Privacy, and Anonymity in Computation, Communication, and Storage. Springer International Publishing, 2018, pp. 443–452.
- [14] D. Lagutin, Y. Kortesniemi, N. Fotiou, and V. A. Siris, “Enabling decentralised identifiers and verifiable credentials for constrained IoT devices using OAuth-based delegation,” in Workshop on Decentralized IoT Systems and Security (DISS 2019), in conjunction with the NDSS Symposium 2019, San Diego, CA, USA, 2019.
- [15] V. A. Siris, D. Dimopoulos, N. Fotiou, S. Voulgaris, and G. C. Polyzos, “OAuth 2.0 meets blockchain for authorization in constrained IoT environments,” in 2019 IEEE 5th World Forum on Internet of Things (WF-IoT), April 2019, pp. 364–367.
- [16] M. Jones, J. Bradley, M. Machulak, and P. Hunt, “OAuth 2.0 dynamic client registration protocol,” IETF, RFC 7591, 2015.
- [17] M. Scurtescu, “OAuth 2.0 token revocation,” IETF, RFC 7009, 2013.
- [18] M. Jones, J. Bradley, and H. Tschofenig, “Proof-of-possession key semantics for JSON Web Tokens (JWTs),” IETF, RFC 7800, 2016.
- [19] S. Dziembowski, L. Eckey, and S. Faust, “Fairswap: How to fairly exchange digital goods,” in Proceedings of the 2018 ACM SIGSAC Conference on Computer and Communications Security, ser. CCS ’18. New York, NY, USA: Association for Computing Machinery, 2018, p. 967–984.
- [20] B. Francis. (2019) Web thing api. [Online]. Available: https://iot.mozilla.org/wot/
- [21] Manu Sporny et al. (2019) Verifiable credentials data model 1.0. [Online]. Available: https://www.w3.org/TR/verifiable-claims-data-model/