MPTCP Linux Kernel Congestion Controls
Abstract
MultiPath TCP (MPTCP) is a promising protocol which brings new light to the TCP/IP protocol stack ossification problem by means of an impactful innovation of the transport layer. A MPTCP connection consists of a set of one or more subflows, where each subflow offers an alternative path to reach a target remote end-system. However, simply applying the standard TCP congestion control on each subflow would give an unfair resource sharing. Various subflows of a connection would dispute bottleneck links with regular single-path TCP connections, leading them to starvation conditions. To deal with this concern, a multipath congestion control algorithm adjusts the sending operation of all subflows in a coupled fashion in order to achieve various objectives, e.g., friendliness, responsiveness, throughput improvement, and congestion balance. In this report, we describe the four coupled congestion control algorithms deployed in the MPTCP Linux kernel implementation, namely: LIA, OLIA, BALIA, and wVegas. We provide a concise material with technical details of each algorithm, while summarizing all of them together from a single notation.
Index Terms:
MPTCP; Coupled Congestion Controls.I Introduction
MultiPath TCP (MPTCP) [1] is a set of TCP extensions that enable reliable data transfer over multiple end-to-end paths between source and destination nodes. Two benefits are forthwith achieved [1]: it improves end-to-end throughput, while allowing greater tolerance to communication failures. As a general-purpose protocol, MPTCP has a broad range of potential uses. Enabling efficient and resilient mobile communications [2, 3], and improving performance improvement of datacenter networks (DCN) [4, 3] are two impactful applications of MPTCP. While MPTCP is now supported by independent implementations in different operating systems (e.g., Linux, Apple iOS, Citrix, FreeBSD, Oracle Solaris), currently its largest deployment is on mobile devices, likely on hundreds of millions of enabled devices [5].
A MPTCP connection consists of a set of one or more subflows . Each subflow provides an alternative path to reach a remote end-system. A subflow starts and terminates as a regular single-path TCP (SPTCP) connection, with its own congestion window, which measures and estimates its state variables, such as RTT. MPTCP packet fields are carried as option into TCP header. Thus, subflow packets are handled as regular TCP packets in the network, which avoids misinterpret and drop of MPTCP packets by middleboxes. This makes easy the deployment of MPTCP on the existing Internet.
Network paths between multihomed relay/end systems have different characteristics (delay, loss, and capacity), in which MPTCP has to deal with. The reality is that there is a diversity of data traffic and transmission technology in the access networks, i.e., there are several different (heterogeneous) network paths on the Internet. Thus, it is a challenge to improve the performance of multipath transfers to allow a higher bandwidth aggregation benefit. While different algorithms have been proposed to improve multipath performance in different network scenarios and applications in the last years, the research effort has been centered around solutions in the scopes of packet scheduling [6, 7, 8, 9, 10], and coupled congestion controls [11, 12, 13, 14, 15].
In this report, we focus on coupled congestion controls and provide a summay of the existing algorithms deployed in the MPTCP Linux kernel implementation. Simply using standard TCP congestion control on each subflow would give an unfair resource sharing, since the subflows in an connection would dispute bottleneck links with regular SPTCP connections leading them to starvation [11]. In addition, the multipath connection undergoes the bottleneck conditions of similar and dissimilar path characteristics. To deal with those concerns, a MPTCP congestion control has to couple and adjust the sending operation of all subflows. In doing so, various objectives are taking into account [16]:
- •
Friendliness when sharing network resources with non-MPTCP flows;
- •
Responsiveness to react to network changes;
- •
Throughput improvement from multipath aggregation bandwidth;
- •
Congestion balance among existing multipaths between two end-systems.
At present, four coupled congestion controls are deployed in the MPTCP implementation [17]: LIA [11], OLIA [12], BALIA [14], and wVegas [15]. Such congestion controls are mostly carried out in the congestion avoidance phase as there are different strategies for additive-increase/multiplicative-decrease (AIMD), so that the other algorithms (slow start, fast retransmission, and fast recovery) occur as in standard TCP [18]. Table I summarizes the strategies of the existing multipath congestion avoidance. We provide details of each coupled congestion control in the next sections.
II Linked Increases Algorithm (LIA)
LIA [11] has three main objectives: to improve throughput at least as well as an SPTCP connection on the best available path; do no harm to other SPTCP connections when sharing common bottlenecks; and balance congestion by moving traffic from most congested paths to least congested ones. To this end, when receiving an ACK on subflow , the subflow’s congestion window is increased by the minimum between two terms. First term describes a multipath window increase defined by , where is a multipath aggressiveness factor, and . The second term is defined by , which represents the window increase of a regular SPTCP connection would get at the same scenario. The aggressiveness factor is such that the multipath goodput is equal to the SPTCP on the best path.
III Opportunistic Linked Increases Algorithm (OLIA)
While LIA forces a tradeoff between optimal congestion balance and responsiveness, OLIA [12] is an alternative that provides simultaneously these both properties. When receiving an ACK on the subflow , the congestion window is increased by adding two terms. The first term is an optimal congestion balancing defined by , where is the round-trip time observed on . The second term is added by , which guarantees responsiveness to react to changes in the current .
Unlike LIA, the parameter is specific to each subflow and applied to shift traffic among the subflows. To this end, subflows are classified into three different sets: – set of subflows with the largest ; – set of best subflows with larger estimates of bytes transmitted on between the last two losses; and – set of the best collected subflows with no larger windows, i.e., and . If all have the largest , then for any , i.e., the aggregate capacity available is using all the best subflows.
When is not empty, there is at least one best subflow with a small , then is positive for all and negative for all . This makes to increase faster for and slower for . As a result, traffic is re-forwarded from subflows fully utilized () to paths with free capacity available ().
IV Balanced Linked Adaptation (BALIA)
LIA might be unfriendliness without any benefit to MPTCP when competing with regular SPTCP flows on shared bottlenecks, while OLIA can be unresponsive to changes in network conditions when the paths experience similar RTTs [19]. From an optimization model designed to guarantee the existence, uniqueness and stability of the network equilibrium, BALIA [14, 19] is an alternative of multipath congestion control that allows oscillation up to an ideal level to provide good balance between friendliness and responsiveness. For the subflow on the best path or for a MPTCP connection of a single path (), we have . This makes both the increment and decrement of to reduce to the same ones of TCP standard [18].
V Weighted Vegas (wVegas)
While LIA, OLIA and BALIA react to path congestion upon packet loss, wVegas [15] is a delay-based congestion control that estimates the link queueing delay to realize path congestion and, then, proactively adapts . The control of wVegas adjusts according to the weight – a ratio between current subflow’s sending rate and the aggregate multipath sending rate. The is adjusted whenever it is smaller than , which is a difference between expected and actual .
On the transmission round on , is adapted in two steps. First, similarly to TCP-Vegas [20], by incrementing or decrementing according to and . Second, by readjusting according to in order to drain link queues. This is conducted by monitoring the variation of queue delay through the difference between the average observed RTT () and the minimum measured RTT (). The value of is decreased by a backoff factor of when detecting the link queue variation is higher than . Such an approach makes subflow to occupy fewer link buffers, while reducing packet loss and mitigating bufferbloat. Thus, wVegas provides a congestion avoidance phase more sensitive to network changes than other congestion controls based exclusivity on the event of packet loss.
VI Conclusions
The adoption of MPTCP is leveraged by its great benefits provided. When extending the TCP, which is implemented at the kernel-space of operating systems, the MPTCP works completely transparent to the user applications running on end-systems. The multipath control data is conveyed as option field in the regular TCP header, which makes it to be easily deployable on the existing Internet infrastructure. The concurrent multipath transfer over subflows established in a connection can improve network resource usage, provide higher throughput and connection failure tolerance to end-systems. However, to obtain such benefits, the subflows have to dispute bottleneck resources with other non-MPTCP flows. To deal with this concern, MPTCP has to take into account different properties of network congestion, such as fairness and friendliness, in order to share bottleneck resources. In this context, the coupled congestion control is an internal MPTCP mechanism which plays a key role on the multipath performance. In this report, we use a single notation to summarize the four existing algorithms of coupled congestion controls deployed in MPTCP Linux kernel implementation. Since the algorithms operate mostly during the congestion avoidance phase, we focus attention on describing technical details of the multipath AIMD strategies.
Acknowledgement
We thank the support of the research project – Grant #2015/18808-0, São Paulo Research Foundation (FAPESP).
References
- [1] A. Ford, C. Raiciu, M. Handley, and O. Bonaventure, “TCP Extensions for Multipath Operation with Multiple Addresses,” IETF, Internet Standart RFC 6824, Jan. 2013.
- [2] C. Paasch, G. Detal, F. Duchene, C. Raiciu, and O. Bonaventure, “Exploring Mobile/WiFi Handover with Multipath TCP,” in Proceedings of the 2012 ACM SIGCOMM Workshop on Cellular Networks: Operations, Challenges, and Future Design. ACM, 2012, pp. 31–36.
- [3] A. Ford, C. Raiciu, M. Handley, S. Barre, and J. Iyengar, “Architectural Guidelines for Multipath TCP Development,” IETF, Internet Standart RFC 6182, Mar. 2011.
- [4] C. Raiciu, S. Barre, C. Pluntke, A. Greenhalgh, D. Wischik, and M. Handley, “Improving datacenter performance and robustness with multipath TCP,” ACM SIGCOMM Computer Communication Review, vol. 41, no. 4, pp. 266–277, 2011.
- [5] O. Bonaventure, C. Paasch, and G. Detal, “Use Cases and Operational Experience with Multipath TCP,” IETF, Internet Standart RFC 8041, Jan. 2017.
- [6] F. Yang, P. Amer, and N. Ekiz, “A Scheduler for MultiPath TCP,” in 22nd IEEE International Conference on Computer Communications and Networks (ICCCN 2013), 2013, pp. 1–7.
- [7] B. Arzani, A. Gurney, S. Cheng, R. Guerin, and B. T. Loo, “Impact of path characteristics and scheduling policies on mptcp performance,” in 28th IEEE International Conference on Advanced Information Networking and Applications Workshops (WAINA 2014), 2014, pp. 743–748.
- [8] C. Paasch, S. Ferlin, O. Alay, and O. Bonaventure, “Experimental Evaluation of Multipath TCP Schedulers,” in Proceedings of the 2014 ACM SIGCOMM Workshop on Capacity Sharing Workshop, ser. CSWS ’14. ACM, 2014, pp. 27–32.
- [9] B.-H. Oh and J. Lee, “Constraint-based proactive scheduling for MPTCP in wireless networks,” Computer Networks, vol. 91, pp. 548–563, 2015.
- [10] B. Y. L. Kimura, D. C. S. F. Lima, and A. A. F. Loureiro, “Alternative scheduling decisions for multipath tcp,” IEEE Communications Letters, vol. 21, no. 11, pp. 2412–2415, Nov 2017.
- [11] C. Raiciu and M. H. D. Wischik, “Coupled Congestion Control for Multipath Transport Protocols,” IETF, Internet Standart RFC 6356, Oct. 2011.
- [12] R. Khalili, N. Gast, and M. Popovic, “Opportunistic Linked-Increases Congestion Control Algorithm for MPTCP,” IETF, Internet Draft draft-khalili-mptcp-congestion-control-05, Jul. 2014.
- [13] D. Wischik, C. Raiciu, A. Greenhalgh, and M. Handley, “Design, Implementation and Evaluation of Congestion Control for Multipath TCP,” in 8th USENIX Symposium on Netwroked System Design and Implementation (NSDI 2011), vol. 11, 2011, pp. 8–8.
- [14] A. Walid, Q. Peng, J. Hwang, and S. Low, “Balanced Linked Adaptation Congestion Control Algorithm for MPTCP,” IETF, Internet Draft draft-walid-mptcp-congestion-control-04, Jan. 2016.
- [15] M. Xu, Y. Cao, and E. Dong, “Delay-based Congestion Control for MPTCP,” IETF, Internet Draft draft-xu-mptcp-congestion-control-04.txt, Jul. 2016.
- [16] C. Xu, J. Zhao, and G.-M. Muntean, “Congestion Control Design for Multipath Transport Protocols: A Survey,” IEEE Communications Surveys & Tutorials, vol. 18, no. 4, pp. 2948–2969, 2016.
- [17] C. Paasch, S. Barré, and et al., “Multipath TCP in the Linux Kernel,” Available from https://www.multipath-tcp.org, 2013.
- [18] M. Allman, V. Paxson, and E. Blanton, “TCP Congestion Control,” IETF, Internet Standart RFC 5681, Sep. 2009.
- [19] Q. Peng, A. Walid, J. Hwang, and S. H. Low, “Multipath tcp: Analysis, design, and implementation,” IEEE/ACM Transactions on Networking (ToN), vol. 24, no. 1, pp. 596–609, 2016.
- [20] L. S. Brakmo, S. W. O’Malley, and L. L. Peterson, “Tcp vegas: New techniques for congestion detection and avoidance,” SIGCOMM Comput. Commun. Rev., vol. 24, no. 4, pp. 24–35, Oct. 1994.
![]() |
Bruno Yuji Lino Kimura received his B.Sc. in Computer Science from the Pontifical Catholic University of Minas Gerais (2005), M.Sc. in Computer Science from the Federal University of São Carlos (2008), and D.Sc in Computer Science from the University of São Paulo (2012), Brazil. Currently, he is an assistant professor at the Federal University of São Paulo. His research interests include multipath data transport, vehicle communication networks, delay/disruption tolerant networks, and mobility management. |
![]() |
Antonio Alfredo Ferreira Loureiro received his B.Sc. and M.Sc. degrees in computer science from the Federal University of Minas Gerais (UFMG), Brazil, and the Ph.D. degree in computer science from the University of British Columbia, Canada. Currently, he is a full professor of computer science at UFMG, where he leads the research group in wireless sensor networks. His main research areas are wireless sensor networks, mobile computing, and distributed algorithms. In the last 10 years he has published regularly in international conferences and journals related to those areas, and also presented tutorials at international conferences. |
![[Uncaptioned image]](1812.03210v1/kimura.png)
![[Uncaptioned image]](1812.03210v1/loureiro.png)