[INFO] +- org.bouncycastle:bcpkix-jdk18on:jar:1.71.1:compile
[INFO] |  \- org.bouncycastle:bcutil-jdk18on:jar:1.71.1:compile

USED TYPES in transitive bcutil-jdk18on-1.71.1.jar -> [
org.bouncycastle.asn1.bsi.BSIObjectIdentifiers,
org.bouncycastle.asn1.cmp.PKIStatus,
org.bouncycastle.asn1.cmp.PKIStatusInfo,
org.bouncycastle.asn1.cmp.PKIFailureInfo (INDIRECTLY used through TimeStampResponse),
org.bouncycastle.asn1.cmp.PKIFreeText (INDIRECTLY used through TimeStampResponse),
org.bouncycastle.asn1.cms.OriginatorInfo,
org.bouncycastle.asn1.cms.RecipientEncryptedKey,
org.bouncycastle.asn1.cms.KeyTransRecipientInfo (directly)
org.bouncycastle.asn1.cms.KeyAgreeRecipientInfo,
org.bouncycastle.asn1.cms.KEKRecipientInfo,
org.bouncycastle.asn1.cms.OtherRevocationInfoFormat,
org.bouncycastle.asn1.cms.CMSAttributes,
org.bouncycastle.asn1.cms.OtherKeyAttribute,
org.bouncycastle.asn1.cms.KEKIdentifier,
org.bouncycastle.asn1.cms.PasswordRecipientInfo,
org.bouncycastle.asn1.cms.OriginatorPublicKey,
org.bouncycastle.asn1.cms.KeyAgreeRecipientIdentifier,
org.bouncycastle.asn1.cms.EnvelopedData (directly),
org.bouncycastle.asn1.cms.Attributes,
org.bouncycastle.asn1.cms.Attribute (directly),
org.bouncycastle.asn1.cms.RecipientIdentifier (directly),
org.bouncycastle.asn1.cms.SignerInfo,
org.bouncycastle.asn1.cms.RsaKemParameters,
org.bouncycastle.asn1.cms.SignerIdentifier,
org.bouncycastle.asn1.cms.ContentInfo (directly),
org.bouncycastle.asn1.cms.CMSObjectIdentifiers,
org.bouncycastle.asn1.cms.IssuerAndSerialNumber (directly),
org.bouncycastle.asn1.cms.OriginatorIdentifierOrKey,
org.bouncycastle.asn1.cms.CMSAlgorithmProtection,
org.bouncycastle.asn1.cms.EncryptedContentInfo (directly),
org.bouncycastle.asn1.cms.SignedData,
org.bouncycastle.asn1.cms.AttributeTable (directly),
org.bouncycastle.asn1.cms.GenericHybridParameters,
org.bouncycastle.asn1.cms.RecipientKeyIdentifier,
org.bouncycastle.asn1.cms.RecipientInfo (directly),
org.bouncycastle.asn1.cms.Time,
org.bouncycastle.asn1.cms.OtherRecipientInfo,
org.bouncycastle.asn1.eac.EACObjectIdentifiers,
org.bouncycastle.asn1.ess.SigningCertificateV2 (INDIRECTLY used through TimeStampToken and TimeStampResponse),
org.bouncycastle.asn1.ess.ESSCertID (INDIRECTLY used through TimeStampToken and TimeStampResponse),
org.bouncycastle.asn1.ess.SigningCertificate (INDIRECTLY used through TimeStampToken and TimeStampResponse),
org.bouncycastle.asn1.ess.ESSCertIDv2 (INDIRECTLY used through TimeStampToken and TimeStampResponse),
org.bouncycastle.asn1.tsp.TimeStampResp (INDIRECTLY used through TimeStampResponse),
org.bouncycastle.asn1.tsp.MessageImprint (directly),
org.bouncycastle.asn1.tsp.TimeStampReq (INDIRECTLY used through TimeStampRequest and TimeStampRequestGenerator),
org.bouncycastle.asn1.tsp.TSTInfo (INDIRECTLY used through TimeStampToken, TimeStampTokenInfo),
org.bouncycastle.asn1.tsp.Accuracy (INDIRECTLY used through TimeStampTokenInfo)]

USED DIRECTLY
import org.bouncycastle.asn1.cms.ContentInfo; used in com.lowagie.text.pdf.PdfPublicKeySecurityHandler and com.lowagie.text.pdf.PdfPKCS7
import org.bouncycastle.asn1.cms.EncryptedContentInfo; used in com.lowagie.text.pdf.PdfPublicKeySecurityHandler
import org.bouncycastle.asn1.cms.EnvelopedData; used in com.lowagie.text.pdf.PdfPublicKeySecurityHandler
import org.bouncycastle.asn1.cms.IssuerAndSerialNumber; used in com.lowagie.text.pdf.PdfPublicKeySecurityHandler
import org.bouncycastle.asn1.cms.KeyTransRecipientInfo; used in com.lowagie.text.pdf.PdfPublicKeySecurityHandler
import org.bouncycastle.asn1.cms.RecipientIdentifier; used in com.lowagie.text.pdf.PdfPublicKeySecurityHandler
import org.bouncycastle.asn1.cms.RecipientInfo; used in com.lowagie.text.pdf.PdfPublicKeySecurityHandler
import org.bouncycastle.asn1.cms.Attribute; used in com.lowagie.text.pdf.PdfPKCS7
import org.bouncycastle.asn1.cms.AttributeTable; used in com.lowagie.text.pdf.PdfPKCS7
import org.bouncycastle.asn1.tsp.MessageImprint; - used in com.lowagie.text.pdf.PdfPKCS7


USED THROUGH bcpkix-jdk18on


https://www.javadoc.io/doc/org.bouncycastle/bcutil-jdk18on/latest/index.html

org.bouncycastle.asn1.bsi: ASN.1 classes specific to the Bundesamt für Sicherheit in der Informationstechnik (BSI) standards.
org.bouncycastle.asn1.cmp: Support classes useful for encoding and supporting PKIX-CMP as described RFC 4210.
org.bouncycastle.asn1.cms: Support classes useful for encoding and supporting Cryptographic Message Syntax as described in PKCS#7 and RFC 3369 (formerly RFC 2630).
org.bouncycastle.asn1.eac: ASN.1 classes specific to the Bundesamt für Sicherheit in der Informationstechnik (BSI) Technical Guideline Advanced Security Mechanisms for Machine Readable Travel Documents.
org.bouncycastle.asn1.ess: Support classes useful for encoding and supporting Enhanced Security Services for S/MIME as described RFC 2634 and RFC 5035.
org.bouncycastle.asn1.tsp:Support classes useful for encoding and supporting Time Stamp Protocol as described RFC 3161.


https://www.javadoc.io/doc/org.bouncycastle/bcprov-jdk18on/latest/index.html

------

USED TYPES in bcpkix-jdk18on-1.71.1.jar -> [
org.bouncycastle.cms.CMSVerifierCertificateNotValidException,
org.bouncycastle.cms.CMSSignatureEncryptionAlgorithmFinder,
org.bouncycastle.cms.CMSTypedStream,
org.bouncycastle.cms.CMSUtils (uses OtherRevocationInfoFormat),
org.bouncycastle.tsp.TSPValidationException,
org.bouncycastle.cert.ocsp.OCSPException,
org.bouncycastle.cms.CMSTypedStream$FullReaderStream,
org.bouncycastle.tsp.TimeStampRequest (used directly by openpdf in TSAClientBouncyCastle, uses TimeStampReq),
org.bouncycastle.cert.ocsp.OCSPReqBuilder$RequestObject,
org.bouncycastle.tsp.TimeStampRequestGenerator (used directly by openpdf in TSAClientBouncyCastle),
org.bouncycastle.cms.CMSRuntimeException,
org.bouncycastle.cms.PasswordRecipientId,
org.bouncycastle.cms.KeyAgreeRecipientInformation,
org.bouncycastle.cms.jcajce.CMSUtils,
org.bouncycastle.cms.CMSProcessableByteArray,
org.bouncycastle.cms.jcajce.EnvelopedDataHelper$JCECallback,
org.bouncycastle.cert.jcajce.JcaX509CertificateHolder,
org.bouncycastle.cms.PasswordRecipient$PRF,
org.bouncycastle.tsp.TimeStampToken (used by openpdf directly in PdfPKCS7 and TSAClientBouncyCastle)
org.bouncycastle.cms.KEKRecipient,
org.bouncycastle.operator.SecretKeySizeProvider,
org.bouncycastle.cms.KeyAgreeRecipient,
org.bouncycastle.cms.RecipientOperator,
org.bouncycastle.operator.GenericKey,
org.bouncycastle.cms.KeyTransRecipientInformation,
org.bouncycastle.cms.CMSEnvelopedHelper$CMSEnvelopedSecureReadable,
org.bouncycastle.cert.selector.MSOutlookKeyIdCalculator$SHA1Digest,
org.bouncycastle.cms.RecipientId,
org.bouncycastle.cert.X509CRLEntryHolder,
org.bouncycastle.cms.PasswordRecipientInformation,
org.bouncycastle.cms.AuthAttributesProvider,
org.bouncycastle.operator.MacCalculator,
org.bouncycastle.cert.ocsp.OCSPUtils,
org.bouncycastle.cms.CMSException,
org.bouncycastle.cms.SignerInformationVerifier,
org.bouncycastle.operator.DefaultSecretKeySizeProvider,
org.bouncycastle.operator.AlgorithmNameFinder,
org.bouncycastle.cert.ocsp.UnknownStatus,
org.bouncycastle.operator.RawContentVerifier,
org.bouncycastle.cms.jcajce.DefaultJcaJceExtHelper,
org.bouncycastle.operator.DigestAlgorithmIdentifierFinder,
org.bouncycastle.cert.CertIOException,
org.bouncycastle.cms.Recipient,
org.bouncycastle.cms.PasswordRecipient,
org.bouncycastle.cms.KeyAgreeRecipientId,
org.bouncycastle.cms.SignerId,
org.bouncycastle.cms.jcajce.JcaJceExtHelper,
org.bouncycastle.cms.CMSSignedData$1,
org.bouncycastle.cms.SignerInformationStore,
org.bouncycastle.cert.selector.X509CertificateHolderSelector,
org.bouncycastle.operator.InputAEADDecryptor,
org.bouncycastle.operator.jcajce.JceAsymmetricKeyUnwrapper,
org.bouncycastle.operator.DefaultSignatureNameFinder,
org.bouncycastle.cms.CMSSecureReadable,
org.bouncycastle.cert.CertException,
org.bouncycastle.cms.CMSAttributeTableGenerationException,
org.bouncycastle.cms.KEKRecipientId,
org.bouncycastle.cms.CMSAlgorithm,
org.bouncycastle.cms.RecipientInformationStore,
org.bouncycastle.cms.CMSSignerDigestMismatchException,
org.bouncycastle.tsp.TimeStampResponse (used directly by openpdf in TSAClientBouncyCastle),
org.bouncycastle.cms.CMSEnvelopedHelper$CMSDigestAuthenticatedSecureReadable,
org.bouncycastle.cms.jcajce.JceKeyTransRecipient,
org.bouncycastle.cms.jcajce.ProviderJcaJceExtHelper,
org.bouncycastle.tsp.TSPException,
org.bouncycastle.cert.selector.MSOutlookKeyIdCalculator$GeneralDigest,
org.bouncycastle.tsp.GenTimeAccuracy,
org.bouncycastle.tsp.TSPUtil,
org.bouncycastle.operator.jcajce.OperatorHelper$OpCertificateException,
org.bouncycastle.operator.SymmetricKeyUnwrapper,
org.bouncycastle.operator.jcajce.JcaDigestCalculatorProviderBuilder$1$1,
org.bouncycastle.operator.AsymmetricKeyUnwrapper,
org.bouncycastle.operator.DigestCalculatorProvider,
org.bouncycastle.cms.CMSSignedData,
org.bouncycastle.cms.CMSEnvelopedDataGenerator,
org.bouncycastle.tsp.TimeStampToken$CertID,
org.bouncycastle.cms.CMSReadable,
org.bouncycastle.operator.InputDecryptor,
org.bouncycastle.cms.CMSEnvelopedData (used by openpdf directly, uses ContentInfo, AttributeTable),
org.bouncycastle.cms.CMSSignatureAlgorithmNameGenerator,
org.bouncycastle.cert.ocsp.RevokedStatus,
org.bouncycastle.cms.jcajce.EnvelopedDataHelper$1,
org.bouncycastle.cms.KEKRecipientInformation,
org.bouncycastle.cms.RecipientInfoGenerator,
org.bouncycastle.operator.jcajce.JcaDigestCalculatorProviderBuilder$DigestOutputStream,
org.bouncycastle.tsp.TSPIOException,
org.bouncycastle.operator.KeyUnwrapper,
org.bouncycastle.operator.jcajce.JcaDigestCalculatorProviderBuilder$1,
org.bouncycastle.cert.selector.MSOutlookKeyIdCalculator,
org.bouncycastle.cert.X509AttributeCertificateHolder,
org.bouncycastle.cert.ocsp.OCSPReqBuilder,
org.bouncycastle.operator.ContentVerifier,
org.bouncycastle.cms.SignerInformationVerifierProvider,
org.bouncycastle.cert.ocsp.SingleResp,
org.bouncycastle.cms.jcajce.NamedJcaJceExtHelper,
org.bouncycastle.cms.KeyTransRecipientId,
org.bouncycastle.cms.jcajce.JceKeyTransEnvelopedRecipient,
org.bouncycastle.operator.OutputEncryptor,
org.bouncycastle.cms.KeyTransRecipient,
org.bouncycastle.cms.CMSEnvelopedHelper$CMSAuthenticatedSecureReadable,
org.bouncycastle.operator.DigestCalculator,
org.bouncycastle.operator.OperatorException,
org.bouncycastle.cms.CMSAttributeTableGenerator,
org.bouncycastle.cms.PKCS7ProcessableObject,
org.bouncycastle.cert.ocsp.BasicOCSPResp,
org.bouncycastle.operator.jcajce.JceGenericKey,
org.bouncycastle.cert.ocsp.Req,
org.bouncycastle.cert.ocsp.OCSPResp,
org.bouncycastle.cms.CMSEnvelopedHelper (uses KeyAgreeRecipientInfo, KEKRecipientInfo),
org.bouncycastle.operator.jcajce.JceKTSKeyUnwrapper,
org.bouncycastle.tsp.TimeStampTokenInfo (used by openpdf directly in PdfPKCS7 and TSAClientBouncyCastle),
org.bouncycastle.cms.SignerInformation,
org.bouncycastle.cert.AttributeCertificateIssuer,
org.bouncycastle.cms.jcajce.JceKeyTransEnvelopedRecipient$1,
org.bouncycastle.cms.jcajce.EnvelopedDataHelper$2,
org.bouncycastle.cert.X509CRLHolder,
org.bouncycastle.cms.SignerInfoGenerator,
org.bouncycastle.operator.ContentSigner,
org.bouncycastle.cms.CMSTypedData,
org.bouncycastle.operator.OutputAEADEncryptor,
org.bouncycastle.cert.ocsp.CertificateStatus,
org.bouncycastle.cms.CMSEnvelopedHelper$CMSDigestAuthenticatedSecureReadable$1,
org.bouncycastle.cms.CMSProcessable,
org.bouncycastle.operator.jcajce.OperatorHelper,
org.bouncycastle.cms.RecipientInformation,
org.bouncycastle.cms.CMSEnvelopedGenerator,
org.bouncycastle.cert.ocsp.OCSPReq,
org.bouncycastle.cert.CertUtils,
org.bouncycastle.cert.ocsp.CertificateID,
org.bouncycastle.operator.jcajce.JcaDigestCalculatorProviderBuilder,
org.bouncycastle.cms.OriginatorInformation,
org.bouncycastle.cert.X509CertificateHolder,
org.bouncycastle.cert.AttributeCertificateHolder,
org.bouncycastle.operator.ContentVerifierProvider,
org.bouncycastle.operator.AADProcessor,
org.bouncycastle.operator.DefaultDigestAlgorithmIdentifierFinder,
org.bouncycastle.cms.CMSSignedHelper,
org.bouncycastle.operator.SignatureAlgorithmIdentifierFinder,
org.bouncycastle.cms.NullOutputStream,
org.bouncycastle.cms.OriginatorId,
org.bouncycastle.cms.jcajce.EnvelopedDataHelper,
org.bouncycastle.operator.OperatorCreationException,
org.bouncycastle.cert.ocsp.RespID,
org.bouncycastle.operator.jcajce.JceSymmetricKeyUnwrapper]
