\begin{lstlisting}[float=ht,captionpos=b, caption=SPARQL query: The most frequently mentioned persons in the 20th century., label=lst:sparql3, frame=single]
SELECT ?personName WHERE {
  ?quotation a qkg:Quotation ;
    so:mentions ?person ;
    so:dateCreated .
  ?person rdfs:label ?personName.
  FILTER(?date >= "1801-01-01" AND ?date <= "1899-12-31") .
} GROUP BY ?person
ORDER BY DESC(COUNT(?person)) LIMIT 5
\end{lstlisting}


SELECT ?personLabel ?qText (GROUP_CONCAT(?text; SEPARATOR = ",") AS ?contexts) (GROUP_CONCAT(?source; SEPARATOR = ",") AS ?sources) WHERE {

  ?quotation so:spokenByCharacter [  skos:prefLabel ?personLabel] ;
  qkg:isMisattributed true ;
  qkg:hasText ?quotationText .
  
  ?quotationText so:text ?qText ;
   qkg:hasContext [
   so:text ?text ;
   so:source ?source
  ] .
                 
} GROUP BY ?personLabel ?qText
LIMIT 10


\begin{lstlisting}[float=ht,captionpos=b, caption=SPARQL query: All texts of the quotations with the most manifestions., label=lst:sparql2, frame=single]
SELECT (GROUP_CONCAT(?text; SEPARATOR=", ") AS ?Texts)
WHERE {
  ?quotation a so:Quotation .
  ?quotation qkg:hasText ?quotationText .
  ?quotationText so:text ?text .
} GROUP BY ?quotation
ORDER BY DESC(COUNT(?quotationText)) LIMIT 1
\end{lstlisting}



---- Statistics -----

SELECT (COUNT(?mention) AS ?m)
WHERE
{
 ?mention a qkg:Mention .
 ?mention so:text ?text .
 FILTER(LANG(?text) = "en") .
} 

PREFIX so: <https://schema.org/>
PREFIX qkg: <https://quotekg.l3s.uni-hannover.de/resource/>
SELECT (COUNT(DISTINCT ?person) AS ?m)
WHERE
{
  
 ?quote so:spokenByCharacter ?person .
 ?quote qkg:hasMention ?mention .
 ?mention a qkg:Mention .
 ?mention so:text ?text .
 FILTER(LANG(?text) = "en") .
} 

--Number of persons, quotes, and quote mentions in English

PREFIX so: <https://schema.org/>
PREFIX qkg: <https://quotekg.l3s.uni-hannover.de/resource/>
SELECT (COUNT(DISTINCT ?person) AS ?persons) (COUNT(DISTINCT ?quote) AS ?quotes) (COUNT(DISTINCT ?mention) AS ?mentions)
WHERE {  
 ?quote so:spokenByCharacter ?person .
 ?quote qkg:hasMention ?mention .
 ?mention a qkg:Mention .
 ?mention so:text ?text .
 FILTER(LANG(?text) = "en") .
} 
--- Quote count by language

PREFIX so: <https://schema.org/>
PREFIX qkg: <https://quotekg.l3s.uni-hannover.de/resource/>
SELECT ?lang (COUNT(DISTINCT(?mention)) AS ?cnt)
WHERE
{
 ?mention a qkg:Mention .
  ?mention so:text ?text .
  BIND(LANG(?text) AS ?lang)
} GROUP BY ?lang
ORDER BY DESC(COUNT(DISTINCT(?mention)))

--- Number of mentions with context:

PREFIX so: <https://schema.org/>
PREFIX qkg: <https://quotekg.l3s.uni-hannover.de/resource/>

SELECT (COUNT(DISTINCT ?mention) AS ?mentions)
WHERE {  
 ?mention qkg:hasContext ?context .
} 


--- Quotes with mentions in different languages

SELECT (COUNT(DISTINCT ?quoation) AS ?cnt)
WHERE {  
  ?quoation qkg:hasMention ?mention1 .
  ?quoation qkg:hasMention ?mention2 .

  FILTER(?mention1 != ?mention2 ) .
  
  ?mention1 so:text ?text1 .
  ?mention2 so:text ?text2 .

  FILTER(LANG(?text1) != LANG(?text2)).
}


-- Number of misattributed quotes

SELECT (COUNT(DISTINCT ?quote) AS ?cnt)
WHERE {  
?quote qkg:isMisattributed True .
}

-- Number of languages

SELECT (COUNT(DISTINCT LANG(?text)) AS ?languages)
WHERE {  
?quote rdf:type qkg:Mention .
  ?quote so:text ?text .

}


-----

# Select persons quoted in three languages

SELECT ?personLabel (COUNT(?quotation) AS ?cnt)
WHERE
{
 ?quotation a so:Quotation .
 ?quotation so:spokenByCharacter ?person .
 ?person skos:prefLabel ?personLabel .
 ?quotation qkg:hasMention ?mention1.
  ?mention1 so:text ?text1  .
 ?quotation qkg:hasMention ?mention2 .
            ?mention2 so:text ?text2  .
 
 
  FILTER(LANG(?text1) IN ("en","it","de")) .
  FILTER(LANG(?text2) IN ("en","it","de")) .
  FILTER(LANG(?text1) != LANG(?text2)) .
  
  FILTER(?mention1 != ?mention2 ) .

} 
GROUP BY ?personLabel
ORDER BY DESC(COUNT(?quotation))
LIMIT 500